How to Model Almost Anything
PTC ACADEMIC PROGRAM

How to Model Almost Anything

COPYRIGHT © 2015, PTC INC.

NOTICE OF RIGHTS

All rights reserved under copyright laws of the United States, United Kingdom and other countries. You may reproduce and transmit in any form (electronic, mechanical, photocopying, recording, or otherwise) all parts of this curriculum/tutorial for educational or informational purposes only. All credit and trademark notices must accompany such reproduction made in whole or in part.

This permission does not extend to the reproduction or use of the PTC logo in any form (electronic, mechanical, photocopying, recording, or otherwise) except solely as the case may be during reproduction or use of this curriculum.

TRADEMARKS

PTC, the PTC Logo, PTC Creo, PTC Mathcad, PTC Windchill, and all PTC product names and logos are trademarks or registered trademarks of PTC and/or its subsidiaries in the United States and in other countries.

ACKNOWLEDGEMENTS

This set of curriculum was written and developed by the PTC Academic Team which included Dr. Jordan Cox, Chris Carr, Mark Cheli, Ayora Berry, Alex Cazacu, Alyssa Walker, Kari Karwedsky, and Abdul Abdulkarim. Teachers in the Massachusetts STEM Certificate Program also contributed by reviewing and testing the exercises contained therein.
Introduction
Overview

How to Model Almost Anything 3rd Edition

Introduction

Product development is one of the most important activities that modern society engages in. It brings goods and services to improve the quality of life of people throughout the world. Preparing the next generation of innovators to be creative and familiar with best practices in product development is the purpose of this curriculum.

This curriculum is structured to provide as much exposure to industry best practices and to the variety of models and activities that occur in product development as is possible. There are 12 exercises and each exercise is typically organized with a hands-on activity to explain the concepts, then a practice model to enforce the learning of the concepts and then a final skills assessment activity that provides another model to demonstrate the acquired skills.

Teachers who are in the classroom are the best practitioners for determining how to integrate curriculum like this into the normal classroom curriculum so that it can enhance and reinforce the standards based curriculum that is being taught. This curriculum is engaging and inspiring and gives students hands-on, active learning experiences. It has been developed and tested in real classrooms and shown to engage and inspire students.

PTC Inc. proudly provides this curriculum as a part of its academic outreach programs in an effort to help inspire and engage the next generation of engineers, scientists, technicians and mathematicians. PTC’s award winning “Engineering of the Future” program has impacted students and teachers all over the world. It is our hope that this new set of curriculum will continue to prepare the next generation of workforce for our customers and help improve the quality of life across the globe.
<table>
<thead>
<tr>
<th><strong>Solid Modeling</strong></th>
<th><strong>Model Structure</strong></th>
<th><strong>Model Analysis</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Solid Modeling" /></td>
<td><img src="image2.png" alt="Model Structure" /></td>
<td><img src="image3.png" alt="Model Analysis" /></td>
</tr>
<tr>
<td>Learn about solid modeling as the language of product development.</td>
<td>Concepts of product model assemblies and part models are presented.</td>
<td>The purpose of models is explored through calculating mass properties and completing mechanism simulations.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Assembly Constraints</strong></th>
<th><strong>Assembling Systems</strong></th>
<th><strong>Assembling Mechanisms</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image4.png" alt="Assembly Constraints" /></td>
<td><img src="image5.png" alt="Assembling Systems" /></td>
<td><img src="image6.png" alt="Assembling Mechanisms" /></td>
</tr>
<tr>
<td>The basics of assembly modeling are presented and components to simple models are added.</td>
<td>Learn about systems engineering and how to sub-divide products into sub-systems and model them with sub-assemblies.</td>
<td>Kinematics and mechanisms are presented through gear trains. Mechanism coupling and simulation are also a part of this exercise.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Concept Development</strong></th>
<th><strong>Preliminary Design</strong></th>
<th><strong>Creating Parts &amp; Assemblies</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image7.png" alt="Concept Development" /></td>
<td><img src="image8.png" alt="Preliminary Design" /></td>
<td><img src="image9.png" alt="Creating Parts &amp; Assemblies" /></td>
</tr>
<tr>
<td>Learn about new part creation with a candy product development challenge. An introduction to drawings is presented as well.</td>
<td>New part creation is continued and expanded where multiple part creation operations are taught in the context of creating a next generation water bottle.</td>
<td>Part creation and assembly modeling of products is explored through the creation of simple Geneva mechanisms. Part drawings are also covered.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Advanced Modeling</strong></th>
<th><strong>A Virtual Laboratory</strong></th>
<th><strong>Calculating Stress &amp; Deflection</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image10.png" alt="Advanced Modeling" /></td>
<td><img src="image11.png" alt="A Virtual Laboratory" /></td>
<td><img src="image12.png" alt="Calculating Stress &amp; Deflection" /></td>
</tr>
<tr>
<td>Advanced modeling operations are explored to create more complicated geometry. Sweep and Blend features are covered in depth.</td>
<td>Simulations using 3D contacts are explored where gravity and the coefficient of restitution are modified to demonstrate 3D motion.</td>
<td>Stress analysis on robot parts are introduced to explain forces and force balances in static structures.</td>
</tr>
</tbody>
</table>
Getting Started

Curriculum Files
This curriculum has a variety of different files associated with it that are required for many of the exercises. Most of these files are the actual part and assembly files that will be used.

Please download the files from here before starting:
http://apps.ptc.com/schools/How_to_model_almost_anything.zip

Once downloaded, you must first extract the files to your desired location before using them for the exercises.

Required Software

PTC Creo 3.0
PTC Creo 3.0 is a suite of different applications. For this curriculum we will focus on PTC Creo Parametric, and a few exercises will use PTC Creo Simulate.

Note: This curriculum unit is not backwards compatible with previous editions of PTC Creo.

If you need a copy of the software, keep in mind that it is always FREE to K-12 students and educators. Please see the below link to register for your copy:

www.ptc.com/go/creoforstudents

Download and installation instructions will be included on the webpage after you submit your registration.
**Configuration (Important!)**

PTC Creo has hundreds of different configuration options that allow the user to tailor its behavior based on what they need most. In large companies, the CAD Administrator will set up these options so everyone’s CAD system works consistent with the company requirements.

To make this curriculum and your introduction to PTC Creo easier we have developed a set of custom configuration and user interface options for you. *If you do not apply this configuration, then the instructions will not match your screen.*

For information on how to download and install this PTC Creo configuration, please see the below guide:

http://apps.ptc.com/schools/references/config_creo_schools.pdf

**Need Help?**

If you find yourself stuck at any point during the curriculum, please feel free to reach out to our experts at PTC.

For questions where you are stuck or would like more information on a particular topic, make a new post on our Schools community. Please remember to include any relevant screenshots, page numbers, etc. A link is included below:

http://communities.ptc.com/community/academic-program/schools-program

For technical support questions, please make a new post on our Academic Support community. A link is included below:

http://communities.ptc.com/community/academic-program/support
Exercise 1
Solid Modeling
UNDERSTANDING HOW TO CREATE MODELS OF PARTS AND PRODUCTS

Introduction

One of the greatest developments evolving out of the computer age is the development of 3-dimensional modeling of parts and products. This makes it easier for designers and engineers to create new parts and products. SOLID MODELING IS THE LANGUAGE OF PRODUCT DEVELOPMENT. When a company decides to develop a new product the ideas must be created as solid models in order for the ideas to become real products.
Since solid modeling is the language of product development it is important to learn how to use it to express new ideas. So let’s get started!

**Exercise 1: Exploring Models of Products**

At the end of this exercise you will be able to:

- Set the working directory and open a model;
- Understand the PTC Creo Screen;
- Recognize the coordinate system and know how to show/hide datums;
- Operate the graphic area view and display options of a model;
- Define a part and an assembly;
- Open a part from an assembly;
- Use display styles and apply colors to surfaces.

Let’s start by opening a model of a deep sea submarine and exploring the parts and procedures of a solid model.

1. **Start PTC Creo Parametric** by double-clicking on the icon or by going to the Start Menu, finding **PTC Creo Parametric**, and selecting it.

2. From the **Home** tab, **Data** group, click **Select Working Directory**. This allows you to set the folder that **PTC Creo Parametric** will use to open and save files.
3. Navigate to the How to Model Almost Anything folder:
   - Double-click the Deep_Sea_Sub folder.
   - Click OK.

4. From the Home tab, click Open:
   - Double-click deep_sea_sub.asm

5. You now have the deep sea sub model open in Creo.
3D solid models are mathematical models of real or virtual parts and products. In this section, we will look at the anatomy and elements of solid models, explore how solid models are organized, and introduce you to the solid modeling tool “PTC Creo.” Before you begin to develop a model, it is important to understand what 3D solid models consist of and how they are constructed.

**Characteristics of a Solid Model**
3D solid models are constructed by adding and subtracting geometric volumes to create the final shape of a part or product. This use of “sums” of geometry has become a language for representing ideas for new parts and products. Let’s begin by exploring the anatomy – or elements – of a solid model.

**Model Anatomy**
A solid model is really a sophisticated mathematical set of equations represented in software; however, you hardly ever have to work with those equations. You are able to create and modify solid models simply by working with two representations of the model: a **procedural representation** and a **graphical representation**.

The **procedural representation** is like a list of instructions, which will produce the solid model when followed. It is called a “Model Tree.” It doesn’t look much like a tree in this view because it is just a list. However,
when we graph the procedural representation with respect to dependencies, it becomes a “tree” graph.

6. In the model tree, notice the procedural representation of the model.

Notice that there are three sections to the model tree. The tree begins at the top with **datums** (coordinate systems & planes) that are important to the model. Next is the list of all of the **parts** in the model. The model is sort of like a big sum of all of the parts. Finally, there is the **insert** location which is the place where a new part can be added. It turns out that the order in which things are added is important.

The **graphical representation** is what the solid model looks like. That is easy to understand. You will use both of these representations when building or modifying solid models.
Coordinate Systems

All geometry is built in reference to a global coordinate system. It is usually referred to as the “origin”. This is simply a point in space that is recognized as the starting point or (0,0,0) location. This point is usually represented by three crossing lines as shown. Product models may have several origins, one for each part in the assembly.

There are also other types of references that are used in solid models such as planes, axes, and points. All of these references are called datums and are typically referred to specifically as “datum planes, datum points, and datum axes.”

A default set of datums includes the origin coordinate system and the three coordinate planes (FRONT: X-Z, RIGHT: Y-Z, TOP: X-Y). Axes can be defined at the intersection of any two of these planes.

Carefully selecting what datums you use as references for creating geometry will make sure that your model is robust (i.e. doesn’t break or fail) and helps ensure that you will be able to create all the different aspects of your model as easily as possible. We’ll show you how to plan these datums and references later and also show you how to create them in PTC Creo.
7. In the graphics area, notice the datum planes, coordinate systems, and spin center are displayed in the model.

8. From the In Graphics toolbar:
   - Click Datum Display Filters and disable the display of all datum features

9. The graphical display of the submarine should now be easier to see since the datums are no longer displayed.
The Art of Solid Modeling

PTC Creo is a suite of tools that helps you build 3D models. One of the tools that we will use to create solid models is called PTC Creo Parametric. PTC Creo Parametric is like a virtual art studio where you can build 3D solid models.

It can be helpful to think of PTC Creo Parametric as a virtual studio made up of different rooms as shown below. There are many different modes or rooms within PTC Creo Parametric where different functions can be completed. Within each of the modes, the tool sets are different. Moving from one mode to another is an important part of PTC Creo Parametric.

When creating part and assembly models, we will use the 3D Part Modeling mode and the 3D Assembly mode. We will also use a 2D Sketch mode in order to create features. Later on we will explore some of the other capabilities.

The other unique aspect of PTC Creo Parametric is the amount of user interaction that is required in creating
geometry. When you think about how you would use your hands, fingers, and all types of tools if you were creating or sculpting in an art studio, you can understand why it requires so much user interaction in creating geometry. Because PTC Creo Parametric is software, the only means of user interaction is through the buttons and motion of the mouse and keyboard. You will find that you will use more buttons and button combinations in interacting with PTC Creo than probably any other program you have used.

Tour of the PTC Creo Screen
Before we start working in PTC Creo Parametric we should take some time to understand the user interface and methods to navigate and view models.

The PTC Creo Parametric user interface is the now familiar Windows Ribbon environment. The Windows Ribbon makes it easy to navigate functions arranged in tabs and groups. The different parts of the main ribbon are shown below. Take some time to familiarize yourself with the various menus as these will be used throughout this modeling activity.
**Orienting the View in Creo Parametric**

PTC Creo Parametric offers easy-to-manipulate model views so that engineers can view their designs from different perspectives.

<table>
<thead>
<tr>
<th>Method</th>
<th>Description</th>
<th>Keyboard</th>
<th>Image</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Rotate</strong></td>
<td>Hold down the middle mouse button and move the mouse.</td>
<td>Middle-Hold + Drag</td>
<td><img src="image1" alt="Image" /></td>
</tr>
<tr>
<td><strong>Zoom in/out</strong></td>
<td>Use the middle mouse button to scroll forward or backward. To zoom into a specific location of your model, move your mouse to that location before scrolling the mouse wheel.</td>
<td>Middle-Scroll: Forward = Out Backward = In</td>
<td><img src="image2" alt="Image" /></td>
</tr>
<tr>
<td><strong>Pan</strong></td>
<td>Hold Shift, then press and hold the middle mouse button. Moving the mouse will then pan the view.</td>
<td>Shift + Middle-Hold + Drag</td>
<td><img src="image3" alt="Image" /></td>
</tr>
</tbody>
</table>

**Display Options in Creo Parametric**

PTC Creo Parametric also has a number of predefined display settings and views to help you visualize your design.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Refit Window</strong></td>
<td>Click to refit your model in the main graphics area. If you somehow “lose” the graphic display of your model, clicking this button will usually get it back for you.</td>
</tr>
</tbody>
</table>
### Named Views

Creo Parametric has a number of pre-defined saved views which enable you to view your model in different orientations such as BACK, BOTTOM, FRONT, and TOP.

<table>
<thead>
<tr>
<th>Datum Display</th>
<th>Plane Display Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>The display of datum features can be toggled on and off from the datum display toolbar.</td>
<td>Planes</td>
</tr>
<tr>
<td></td>
<td>Axes</td>
</tr>
<tr>
<td></td>
<td>Points</td>
</tr>
<tr>
<td></td>
<td>Coordinate Systems</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Model Display</th>
<th>Model Display Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>The display of your model can be quickly set from the model display toolbar.</td>
<td>Wireframe</td>
</tr>
<tr>
<td></td>
<td>Hidden Line</td>
</tr>
<tr>
<td></td>
<td>No Hidden</td>
</tr>
<tr>
<td></td>
<td>Shading</td>
</tr>
<tr>
<td></td>
<td>Shading With Reflections</td>
</tr>
</tbody>
</table>

This was a brief introduction to the PTC Creo Parametric User Interface. As you progress through this activity you will explore and use many more functions within PTC Creo Parametric.
10. Move your cursor over the center of the sub and then:
   - Roll the middle-mouse wheel away from you to zoom out.
   - Roll the middle-mouse wheel towards you to zoom in.

   *Creo zooms in or out from the location of your cursor when you roll the mouse wheel. To zoom in near your sub’s engines, move your cursor there before rolling the mouse wheel.*

11. Hold down the middle-mouse wheel and drag your mouse to spin the sub.
12. Hold down the **SHIFT** key and middle-mouse wheel while you drag your mouse to move or “pan” your model.

13. When there are parts of the model that can move – like the arms, lights, and engines of the sub – press and hold down the **CTRL** and **ALT** keys while left-clicking and dragging the parts to move them.

**Sum of Parts**

When modeling a product or assembly, most of the model tree consists of a list of parts. These parts can be single parts or sub-assemblies of parts (sort of like a model inside of a model). This means that there are relationships between the parts in the list. All of the parts in a model are
the children of that model. The top-level model is the parent. These relationships are referred to as Parent-Child relationships and represent which models own what parts.

It is these types of relationships that turn the model tree from a list into a tree. These relationships will become important to you as you build your own models.

14. To the left of the graphics display, locate the **Model Tree**.

15. Identify the three parts: **Datums**, **Parts**, and **Insert Here** location.

16. Place the cursor over the **BODY.ASM** component in the model tree and notice that it causes the graphic model of the body to be highlighted.

   *You can explore each of the parts in the product model this way. Notice that if you place the cursor on the graphical model, the parts will highlight and the corresponding entries in the model tree will be underlined.*
17. In the model tree, right-click on **BODY.ASM** and select **Open** from the pop-up menu.

*To open a pop-up menu, you must select something and then hold down your right-mouse button.*

---

You have opened the part model of the body of the Deep Sea Submarine. You can see that the model tree only includes the parts that make up the body.
18. From the **Schools** tab, **Models** group, click on 

- **Windows:**

  - Notice that you now have two windows open and that the **BODY.ASM** window is the active one since it has a check mark by it.

  *This is how you manage multiple models when you have more than one window open. The view tab allows you to switch between windows or models. The check mark indicates which window is active. You can only make changes to a model in the active window.*

19. In the Model Tree, left click the gray triangle ➤ next to **INNER_SPHERE.prt** to see a list of its features.

**Sum of Features**

So far we have talked about how models of products or assembly models are made up of a collection of parts. What about the model of a single part? It isn’t a collection of parts; instead it is a collection of **geometric features**.
Geometric features are “chunks” of geometry that make up the model of the part. If we look at the model tree of a part model we will see these features.

**Part models** are different from assemblies or models of products (collections of parts). Part models can have positive and negative features. The **features** – or chunks of geometry – can add solid geometry or can subtract solid geometry.
20. From Schools tab, click Close to close the model of the body.

Display Styles
There are several different display styles that you can use to better explore your models. These display styles allow you to show the model as a solid or an outline where only the edges are displayed. Try each of these styles so that you are familiar with them. It is also possible to change the colors of the model.

21. From the In-Graphics toolbar, click Display Style.

Notice that there are six different display styles for the graphical representation of the model.

22. Try each of the styles and see how it changes the model display.

23. Choose whichever display style you prefer to work with.
24. From the **Schools** tab, **Display** group, click the drop-down menu under **Appearance Gallery**.

25. Select a color and then left-click on the part you wish to change to that color.

   *In an assembly model you can only change the color of an entire part. If you want to change the color of a portion of a part, then you must open the part model and make the changes in that new window.*

26. In the **Select** dialog box in the upper-right corner of your screen, click **OK**.

   *Notice that the color of the part you selected has been entirely changed.*

   *If you want to change the color of different portions of a part you must open the part model.*

27. From the **Schools** tab, **Close** to close the Deep Sea Sub.

28. From the **Home** tab, **Data** group, click **Erase Not Displayed**. Click **OK** to clear the session from memory.

   *This clears the assembly model and parts models from the internal memory of the computer so that you can open new models.*

   *All of the files are still in the folders on your computer.*
**Review**

So let’s review; there are two types of solid models: an **assembly model**, which is a collection of part models for modeling products, and **part models**, which are collections of positive and negative chunks of geometry called **features**.

There are two types of representations for these models: **procedural (model tree)** and **graphical**. We will use both in creating and modifying these models.

There are references used in the creation of the models called **datums**. These consist of **coordinate systems**, **datum points**, **datum planes**, and **datum axes**.

PTC Creo Parametric is like a virtual art studio with different rooms that correspond to the different modes within PTC Creo Parametric for doing sketches, 3D modeling, assembly, etc.

You use your mouse to orient models in PTC Creo Parametric. Scrolling the middle mouse wheel zooms in and out of the model. Pressing down the middle mouse button and moving the mouse rotates the model. Pressing the Shift key while holding down the middle mouse button and moving the mouse pans the view.

Before we open a new model, let’s review what we did with the Deep Sea Sub:

1. Set the Working Directory (Steps 2-3)
2. Opened the assembly model (Step 4)
3. Turned off the datum displays (Step 8)
4. Zoomed, rotated, and panned the model (Steps 10-13)
5. Moved the arms of the deep sea sub (Step 13)
6. Used the model tree to highlight each part in the assembly (Step 16)
7. Opened one of the part models (Step 17)
8. Closed the part model (Step 20)
9. Changed the display style of the graphic representation (Step 21)
10. Change the color of a single part (Steps 24-26)
11. Closed the sub and erased the session from memory (Steps 27-28)
Practice Exercise

Let’s try each of these steps again with a different model.

1. Set your working directory to the **Quadcopter** folder and open the **quadcopter.asm** model.
2. Try repeating all of the steps you did with the Deep Sea Sub using the instructions for reference.
3. Try moving the propellers since the Quadcopter doesn’t have any arms.

Now that you have reviewed and practiced each of the steps with a new model, see if you can answer these questions:

1. What is the purpose of setting a working directory?
2. How do you open a model file in PTC Creo Parametric?
3. How do you turn off the display of the datums?
4. Explain how to zoom, rotate, and pan a model.
5. How do you move any of the moving parts in a model?
6. How do you identify in the model tree the parts you see in the graphical display?
7. Can you open any of the parts in the assembly model in a new window? How?
8. How do you close a model and its associated window?
9. How many different display styles are there for a model? What do they look like?
10. Explain how you change a part’s color.
11. After you close a model, why do you need to erase it from memory and how do you do it?
**FINAL ASSESSMENT**

You will be working with the `glider.asm` model in the `Glider` folder. Do the following steps. At the end of each step do a screen capture and save the picture using the step number as its name. Your screen images do not have to match EXACTLY the pictures shown. The pictures shown are to help as references.

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Set the working directory and open the model. Turn off the display of the datums.</td>
</tr>
<tr>
<td>2.</td>
<td>Open the cockpit and move the control stick to watch the ailerons move.</td>
</tr>
<tr>
<td>3.</td>
<td>Open the landing gear doors underneath the cockpit and deploy the landing gear.</td>
</tr>
</tbody>
</table>
4. Change the color of the tail.  
   *To select the entire tail, you will need to highlight it in the model tree.*

5. Open the landing_gear.asm model.

6. Close the landing gear model.

7. Highlight the tail in the model tree so that it is highlighted in the graphical representation.

8. Change the display style to Hidden.
9. Close the model and erase it from memory.

Congratulations! You have completed this exercise.
Exercise 2

Model Structure
Product Models and Part Models

Product – or assembly – models are collections of part models. A part model is a sum of positive and negative features or chunks of material as shown below:

These two types of models allow designers to create part models of all the parts that make up a product and then assemble them into the model of a product. This “cool” bike was made by creating part models of the wheels, frame, pedals, seat, handlebars, etc. and then combining them into an assembly model that represents how the bike will look and operate as a complete product.
1. Start **PTC Creo Parametric** by double-clicking on the icon or by going to the Start Menu, finding **PTC Creo Parametric**, and selecting it.

2. From the **Home** tab, **Data** group, click **Select Working Directory**.
   
   *This allows you to set the folder that PTC Creo Parametric will use to open and save files.*

3. Navigate to the **How to Model Almost Anything** folder:
   - Double-click the **Cool_Bike** folder.
   - Click **OK**.
4. From the **Home** tab, click **Open**.
   - Double-click `cool_bike_top_assembly.asm`.

5. From the In Graphics toolbar:
   - Click **Datum Display Filters** and disable the display of all datum features.

---

**Parts and Solid Modeling Operations**

Part models represent the “solid” material that makes up a part. The solid material could be made of anything like plastic or metal. In the computer, this solid material is represented by volumes that are assigned material properties like density and material type. Building part models using volumes is referred to as “Solid Modeling.” Creating the volumes that represent solid material is accomplished by creating features – or subsets of volume that are added and subtracted to make the final part volume.

For example, the bike frame is constructed by creating an initial volume (a positive feature) and then cutting away portions of that volume using subsets of negative volume (a negative feature) to create the final shape.
As discussed previously, part models are collections of positive and negative features. Let’s talk about features and how they are constructed. Features are “chunks” of geometry that can be positive or negative. They are simply volumes. When constructing the model of a part, volumes are added or subtracted to create the final shape. This is much like using Venn diagrams to create set theoretic sums.

The “sets” in our solid modeling context are collections of points within a volume. Each volume represents a different set of points and these volumes can be unioned, differenced, or intersected. First, we must
construct the volumes. Then we can apply the set theoretic operations of union and difference.

**Constructing Volumes or Features**

You are probably familiar with primitive geometric shapes, such as spheres, cubes, and pyramids. Since these are 3D shapes, they have a defined volume. Analyzing these 3D shapes, you will notice they are constructed from extending 2D sketches into 3D. This is the process we will use when creating features in PTC Creo Parametric, which will result in forming our models. There are four basic operations for doing this and we will look at each one.

First of all, we must start with a 2D sketch. There are special requirements for creating a robust 2D sketch which we need to follow:

1. 2D sketches must be on the same plane.
2. 2D sketches must be closed, meaning there are no openings in the sketch.
3. 2D sketches should not have any dangling edges or free floating geometry.

Let’s look at each of these cases:

Once we have a good 2D cross section, we can use it to create volume using four different operations that extends it into 3D space.

**Four Operations**

There are four basic operations that are used to create volumes or features.
**Extrude** is taking a cross-section and extending it in a straight line into 3D as shown.

**Revolve** is taking the cross-section and revolving it about an axis as shown.

**Sweep** is taking the cross-section and sweeping it along a curve as shown.
**Blend** is taking two or more cross-sections and blending between them along a curve.

Using these four operations, it is possible to construct a significant number of 3D models. There are other additional operations, but since these four can represent almost all types of 3D parts, we will work with them first.

**Boolean Addition and Subtraction**
Once you have created a volume, you can then create a second volume and add or subtract it from the first one to create a new shape. This can continue volume after volume until you have created the final shape of the part you desire. For example, here is a sphere and a rectangular cube. In the first situation they are added together. In the second the rectangular cube is subtracted from the sphere.
Therefore, using the four operations for creating volumes and then adding or subtracting them allows for a great deal of diversity in the 3D models.

6. In the model tree:
   - Right-click **COOL_BIKE_FRAME.PRT** and then select **Open** from the pop-up menu.
   *To open a pop-up menu you must first select something and then hold down your right-mouse button.*

7. Left-click and drag the ➔ **Insert Here** arrow up and release it, just under the **Extrude 5** feature.
   *Notice that this is the first volume in the model tree. Since it creates solid material, it is a positive feature.*
8. Click \( \text{Expand} \) to expand the **Extrude 5** feature.

9. Right-click on **Section 1** and select **Edit Definition**.

You have entered the Sketch mode of PTC Creo Parametric. The 2D sketch that was extruded to make the first volume is now displayed.

*In this mode, you are able to make changes to any of the parameters of the sketch.*

10. Click \( \checkmark \) **OK** to accept the cross-section and exit out of Sketch mode.
11. Drag the ➤ Insert Here arrow below Extrude 6.

*Notice that Extrude 6 removes solid material. This is a negative feature.*

12. Click ➢ to expand the Extrude 6 feature.

13. Right-click on Section 1 and select ✈ Edit Definition.

You again have access to the section parameters and can see how the section was created using five line segments.

14. Click ✔ OK to accept the cross-section and exit out of Sketch mode.
15. Drag the \textbf{Insert Here} arrow below \textbf{Chamfer 2} at the bottom of the Model Tree.

You can see that there are many different features that make up the cool bike frame model including chamfers and rounds, which angle or round the edges of the volumes.

Notice also that there is a \textbf{Shell} feature. A shell feature hollows out the volume and makes the walls of the volume thin, like a tin can.

16. Rotate and zoom the model to explore the different features.

Materials can also be assigned to the models to ensure that all of the calculations and simulations are in the context of the appropriate material properties. For example, calculating the weight of a part requires the appropriate material density.

Now that we have the final volume for the frame of the bike, we can assign material properties to it so that it represents the type of material we want to make it out of.

17. From the \textbf{File} tab, select \textbf{Prepare}, then select \textbf{Model Properties}. 
Notice that a material has not been assigned to this part.

18. From the Model Properties dialog box, select **change** to the right of **Material**.

19. From the Materials dialog box, double-click on a material to select it and assign it to the model.

20. To see the material properties, right-click on the material and select **Properties**.
The Material Definition dialog box will show the values of the material properties including the density and other important factors.

21. In the Material Definition dialog box, click **Cancel**.

22. In the Materials dialog box, click **OK**.

23. In the Model Properties dialog box, click **Close**.

Let’s change some colors on this part model to see how it is different from changing colors in an assembly model.

24. From the **Schools** tab, **Display** group, click the drop-down menu under **Appearance Gallery**.

25. Select a color by left-clicking on it.
26. Move the cursor over the part model and notice how each of the individual surfaces highlight as you move over them.

This shows which surfaces will be selected when you click. If you want to select more than one surface at a time, hold CTRL on the keyboard while you click.

27. Once you have selected all of the surfaces you want to color, click **OK** in the upper-right corner of the screen.

---

**Editing Part Models**

Once a part model has been created, it is possible to edit its features and make changes to it. Since there are two representations of the model – the procedural representation (model tree) and the graphical representation – it is possible to “go back in time” and walk step-by-step through the construction of the part model to see how it was constructed. Let’s start with a model of a “cool car” and focus on the part model of one of the wheels.

By moving the **Insert Here** arrow up and down in the model tree you can move back to the first feature and then step one feature at a time through the construction of the model.
The procedural representation is like a software program. You can make changes to the parameters or dimensions and then the model can be regenerated, which means that it is re-executed to incorporate all of the changes.

28. From the Model Tree, right-click on \texttt{HANDLE\_BARS} and select \texttt{Edit} from the pop-up menu.
29. Double-click on the dimension **6.000** as shown.

30. Change the value to **8.000** and press **ENTER**.

Notice that the holes change position automatically. When you edit the parameters, PTC Creo Parametric automatically regenerates the procedural representation to create the new model.

31. From the **Schools** tab, click **Close** to close the model of the bike frame.

Notice that when you close the part file, you are returned to the cool bike assembly model and the color changes have been added to the model.
However, if you look closely, the changes in the hole locations have left the handle bars misplaced. In order to update the model, we need to make PTC Creo Parametric regenerate.

32. From the **Schools** tab, select **Regenerate** to update the model.

Notice that the handle bars are now in the correct location.

33. From the **Schools** tab, click **Close** to close the Cool Bike.

34. From the **Home** tab, **Data** group, click **Erase Not Displayed**.

35. Click **OK** to clear the session from memory.
**Review**

There are two types of models: **part models**, which are sums of positive and negative volumes, and **product models**, which are assemblies of part models.

There are four basic operations that are used to create part models:

1. **Extrude** – extending a 2D cross section in a straight line to create a volume
2. **Revolve** – revolving a 2D cross section around an axis to create a volume
3. **Sweep** – sweeping a 2D Cross section along a path to create a volume
4. **Blend** – blending multiple 2D cross sections into a volume

Once the volumes are created, they are summed using Boolean algebra. This means that the volumes can be **positive** (to add material) or **negative** (to subtract material) and when summed they produce the final part shape. Creating part models using volumes is called **Solid Modeling**.

The procedural representation of the part model is really a software program that can be re-executed to produce a new model by changing parameters in the volumes and then **regenerating** the model.
Let’s review what we did with the cool bike model:

1. Set the working directory and opened the assembly model of the cool bike. (Steps 1-4)
2. Explored a part model by moving the **Insert Here** arrow in the model tree. (Steps 7-15)
3. Examined the sketches that were extruded to make positive and negative volumes. (Steps 8-13)
4. Assigned material properties to the model. (Steps 17-23)
5. Changed the color of the surfaces of the model. (Steps 24-27)
6. Edited the parameters of the model and updated the assembly model using the Regenerate tool. (Steps 28-32)
7. Closed the model and erased it from session memory. (Step 33-35)

**Practice Exercise**

Let’s try each of these steps again with a different model.

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Step 2</th>
<th>Step 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set your working directory to the <strong>Cool_Car</strong> folder and open the <strong>cool_car_top_level_assembly.asm</strong> model.</td>
<td>Try repeating all of the steps you did with the Cool Bike using the instructions for reference.</td>
<td>Try opening the <strong>COOL_CAR_BODY.PRT</strong> and exploring how it was made as well as assigning it a material and changing its colors.</td>
</tr>
</tbody>
</table>
Now that you have reviewed and practiced each of the steps with a new model, try answering these questions:

1. What does the Insert Here arrow do when you move it up and down in the model tree?
2. Why is it useful to move the Insert Here arrow in the model tree?
3. How do you examine the sketches that were extruded to create the volumes?
4. How do you assign a material property to a model?
5. How do you change the colors of the surfaces of a part?
6. How is changing the color of surfaces different than changing the color of a part in an assembly model?
7. Can you change the values of the parameters of a part? How?
8. How do you update a model when the parameters have changed?
## Final Assessment

You will be working with the `cool_plane.asm` model in the `Cool_Plane` folder. Do the following steps. At the end of each step take a screen capture and save the picture using the step number as its name. Submit these pictures for grading.

1. Set the working directory and open the model. Turn off the display of the datum.

2. Open the `COCKPIT.PRT` and move the `Insert Here` arrow up under the first revolve.

3. Examine the sketch that was revolved to create the cockpit volume.

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Set the working directory and open the model. Turn off the display of the datum.</td>
</tr>
<tr>
<td>2</td>
<td>Open the <code>COCKPIT.PRT</code> and move the <code>Insert Here</code> arrow up under the first revolve.</td>
</tr>
<tr>
<td>3</td>
<td>Examine the sketch that was revolved to create the cockpit volume.</td>
</tr>
</tbody>
</table>
4. Move the Insert Here arrow back to the bottom of the Model Tree.

5. Assign plastic_acrylic material properties to the model of the cockpit.

6. Change the color of the outside surface of the cockpit.
7. Change the value of the parameter of Extrude 3 so that it places the hole 0.60 units from reference point.

8. Close the cockpit model and update the Cool Plane assembly model so that the tail assembly fits into the hole correctly.

9. Close the Cool Plane assembly and erase it from the session memory.

Congratulations!!! You have completed this exercise.
Exercise 3

Model Analysis
Model Analysis & Simulation

USING MODELS TO UNDERSTAND FORCES, MOTION, & PROPERTIES

Model Analysis

When products are being developed in a product development process, a necessary step is to predict how they will perform in the real world. One of the objectives in building models of parts and products in PTC Creo is to discover how they might function in the real world, BEFORE they are actually built. Once a model has been created, it can be interrogated to learn length, width, surface area, volume, angles, diameters, etc. These types of measurements help designers determine whether their proposed designs will fit in a given location, will be too heavy or too light, or will cost too much.

Let’s get started looking at measurements in PTC Creo.

1. Start PTC Creo Parametric by double-clicking on the icon or by going to the Start Menu, finding PTC Creo Parametric, and selecting it.

2. From the Home tab, Data group, click Select Working Directory.

   Remember that this allows you to set the folder that PTC Creo Parametric will use to open and save files.
3. Navigate to the **How to Model Almost Anything** folder:
   - Double-click the **Ornithopter** folder.
   - Click **OK**.

4. From the **Home** tab, click **Open**:
   - Double-click **top_level_assembly.asm**.

5. Notice that the datum planes are displayed.

6. In the model tree, notice the procedural representation of the model.
7. From the In Graphics toolbar:
   - Click **Datum Display**
     Filters, and disable the display of all datum features.

*This is a model of Da Vinci’s Ornithopter.*

If the model of the Ornithopter were to be made of wood, it would be helpful to know how much total wood would be required to determine the cost of the final kit. PTC Creo can calculate the total volume of an assembly like this very quickly.

8. From the **Analysis** tab, **Measure** group, click **Measure**.

9. In the **Measure** dialog box, select **Volume**.
10. Select the entire assembly by left clicking on \textbf{TOP\_LEVEL\_ASSEMBLY.ASM} in the Model Tree.

11. The total volume of the Ornithopter will now be displayed.

If each part was made out of the same type of wood, the cost of the entire kit of materials would then be:

\[
\text{Total Cost} = (45.2584 \text{ in}^3) \times (\text{Price of Wood } \$ / \text{in}^3)
\]

This is very useful for predicting the cost of manufacturing products.

It is also possible to determine length, width, diameter, angle, etc. Let's try measuring some of these values.
12. From the **Measure** dialog box, click **Length**.

13. Measure the length of one of the edges in the Ornithopter by left-clicking on it as shown.

14. From the **Measure** dialog box, click **Angle**.

15. To measure the angle between two edges, left-click on the first edge and then press and hold the **CTRL** key while left-clicking the second edge.

16. From the **Measure** dialog box, click **Diameter**.

17. Left-click on the outer edge of one of the gears to measure its diameter.
18. From the **Measure** dialog box, click **Area**.

19. Left-click on a flat surface to measure surface area.

20. Close the **Measure** dialog box by clicking the **X** in the upper right-hand corner.

There are other properties that are important in understanding how a product will behave in the real world. For example, the center of gravity of a product represents the point at which all its mass seems to be acting. This is important for tipping studies. If the center of gravity is too high with respect to the overall shape of the product, there may be a chance that the product will tip over. PTC Creo can calculate the center of gravity of a model mathematically.
It is very difficult to calculate the center of gravity without a computer model even if you were to build it out of real materials.

There are other properties that are related to the mass of the product and are therefore called “mass properties.” These include volume, weight, moments of inertia, etc. All of these can be calculated for a given part or assembly.

21. From the **Analysis** tab, **Measure** group, select **Mass Properties**.

22. In the **Mass Properties** dialog box, click **Preview**.
Notice that the volume, surface area, average density and mass have all been calculated. You can scroll down to see the other properties. Note that the center of gravity is displayed as a coordinate system in the graphics area.

23. Click OK to close the **Mass Properties** dialog box.

All of these mass properties depend on the material you will make the parts out of. Therefore, it is easy to explore the differences by changing the materials. This can be helpful in determining which materials to use when building the product.

Units become important as well. It is easy to translate a model from one set of units to another.
24. From the File tab, select Prepare, and then click Model Properties.

25. From the Model Properties dialog box, click change next to Units.

The Units Manager dialog box will allow you to change the units of your model. For now we’ll keep the original units.

26. Click Close in the Units Manager dialog box and Close the Model Properties.

Simulation of the Real World

Now that we are able to measure the shape and size as well as the mass properties of a product, we can simulate how the product will behave in the real world. To simulate, we need to move to a different mode within PTC Creo Parametric.
27. From the **Schools** tab, click **Mechanism**.

   This moves you into the mechanism mode which is a virtual laboratory where you can perform different experiments with the model.

![Mechanism Mode](image)

*Notice that new symbols appear on the model that represent motion joints and gear connections.*

28. In the Mechanism Tree, expand **ANALYSES** by clicking on the gray arrow next to it.

29. Right-click **Wing Flapping (KINEMATICS)** and select **Run**.

   *This will start the simulation and PTC Creo Parametric will calculate all the positions for the flapping of the wings.*
30. Once the simulation is complete, expand the PLAYBACKS.

31. Right-click **Wing_Flapping** and select **Play**.

---

**Collecting Data**

Now that you have calculated a simulation of the wings flapping, it will be valuable to collect data that can be used to analyze the motion of the wings in terms of position, velocity and acceleration. Fortunately, since the simulation was done in the computer, it is possible to take data at any point on the model.

32. In the **Animate** dialog box, click **Play** to start the animation and use the slider to speed up or slow down the playback.

   *You can also capture the simulation as a video using the Capture button so that it can be played outside of PTC Creo.*

33. Click **Close**.
34. From the **Mechanism** tab, **Analysis** group, select **Measures**.

35. In the **Measure Results** dialog box, click **Create new measure**.

36. In the **Measure Definition** dialog box, change the name to **Position**.

37. Left-click on a point at the end of the wing as shown and click **OK**.
38. Create another measure by clicking on Create new measure again and then changing the name to Velocity.

39. In the drop-down menu under Position, change the type to Velocity.

40. Left-click on the same point on the end of the wing and click OK.

41. Repeat steps 37 – 39 to create a measure called Acceleration and change the type to Acceleration.

42. Click on the same point on the end of the wing and then click OK.
43. In the **Measure Results** dialog box, select all three data measures by holding down the **CTRL** key and left-clicking on all three.

44. Under Result set, left-click on **Wing-Flapping** to select it.

45. Click the **Graph** in the upper part of the **Measure Results** dialog box to see the results.
46. **Close** the **Measure Results** dialog box.  
   *Keep the Graphtool open while closing.*

47. In the Mechanism Tree, right-click on **Wing_Flapping** under **PLAYBACKS** and select **Play**.

48. Use the buttons in the **Animate** dialog box to play the animation. A red bar shows the location in the plot of the data.
49. Close all of the dialog boxes and select **Don’t Save** to exit out of **Mechanism** mode.

50. From the **Schools** tab, click **Close** to close the Ornithopter.

51. From the **Home** tab, **Data** group, click **Erase Not Displayed**. Click **OK** to clear the session from memory.

---

**Review**

Let’s review what we have been able to do with the Ornithopter model:

1. Measured the total volume, lengths, angles, diameter, and surface area of parts in the model (Steps 8-20)
2. Calculated the mass properties and center of gravity of the model (Steps 21-23)
3. Learned how to change the units of the model (Steps 24-26)
4. Simulated motion of the wings flapping by running a simulation (Steps 27-31)
5. Collected data from the simulation and graphed it (Steps 31-48)

These measurements, simulations, and data collection are very powerful tools that help designers create new products.
Practice Exercise

Let's try each of these actions again but with a new model.

1. Set your working directory to the **Jet_Pack** folder and open the **jet_pack.asm** model.

2. Try repeating all of the steps you did with the Ornithopter using the instructions for reference.

3. The simulation will activate all of the motion in the model so the wings, arm controls, and heads-up displays will move. You can take data on any of them.

Now that you have had a chance to practice each of the steps in the simulation exercise with a new model, try answering these questions:

1. Why is a model useful for making measurements and how do you make those measurements in PTC Creo?
2. What types of measurements can you make in PTC Creo?
3. Do you have to select all of the parts separately in order to calculate the TOTAL volume of the assembly? How can you select the entire assembly?
4. What are mass properties and why are they important in the design of a product?
5. How do you change the units of a model?
6. What is simulation and how is it important in the design of a product?
7. How do you collect data from a simulation?
Final Assessment

You will be working with the 0_FTC-Robot.asm model in the FTC Robot folder. Do the following steps. At the end of each step take a screen capture and save the picture using the step number as its name.

1. Measure the total volume of the robot.

2. Calculate the center of gravity of the robot.
3. Show how to change the units of the model.

4. Run the simulation called: “Robot” and click OK.
5. Take data for the position of the top of the hooks and plot the data.

Congratulations!!! You have completed this exercise.
Exercise 4
Assembly Constraints
Assembling Product Models

Creating Product Models by Assembling Parts and Subassemblies

Product Models

Assembling parts and subassemblies into a complete model of a product is a part of the product development process. It is the integration of all of the parts and pieces that make up a product.

Defining how parts come together in an assembly requires the application of constraints that reduce the degrees of freedom of a part. There are 6 degrees of freedom for any given part. Three of these degrees follow the translation axes and they are forward to back, side to side, and up and
down movement. The other three follow rotation axes and rotate around the X, Y, and Z axes.

Constraints are applied to reduce the degrees of freedom so that parts are oriented to each other in the appropriate ways. It’s easier to understand as you do it, so let’s get started.

We’ll begin by applying some basic constraints to an easy model and then move on to more complex examples. The process of assembling product models is called system integration and is an important part of product development.

1. Start **PTC Creo Parametric** by double clicking on the icon or by going to the Start Menu, finding **PTC Creo Parametric**, and selecting it.

2. From the **Home** tab, **Data** group, click **Select Working Directory**

   *Remember that this allows you to set the folder that PTC Creo Parametric will use to open and save files.*
3. Navigate to the **How to Model Almost Anything** folder:
   - Double-click the **Peg_Block_Assembly** folder.
   - Click **OK**.

4. From the **Home** tab, click **New**:
   - Change the type of file to **Assembly**.
   - Type in "**Peg_assembly**" for the file name.
   - Click **OK**.

5. From the In Graphics toolbar:
   - Click **Datum Display Filters** and disable the display of all datum features.
6. From the **Schools** tab, **Assembly** group, click **Assemble**.

7. Select **assembly_block.prt** and click **Open**.

   *The part will follow your cursor until you left-click to drop it in the Graphics Area.*

8. Left-click anywhere in the Graphics Area to drop the part.

   *The Orientation Sphere helps you reposition a part once you have dropped it.*
The first part in an assembly doesn’t have any other parts to reference, so it needs to be locked to the origin.


Default locks the model to the origin. If the first part is not placed as default, then any kinematic constraints will not function properly.

Notice that the part has changed color, the orientation sphere has disappeared, and it has the “STATUS” of Fully Constrained.

10. Click the green checkmark ✓ to complete placing the component.

Now that the first part is in place we can assemble other parts to it. If we were to assemble a peg into one of the holes in the block it is intuitive that we would insert it into the hole until it comes to rest. On a computer it is less intuitive. We need to place constraints on the peg until it comes to rest with the right placement.
The first constraint we would use is to make the axes of the peg and the hole coincident so they would line up. You can think of coincident as another word for “touching”. Next we would need to make the underside of the head of the peg coincident with the top of the block.

Assigning assembly constraints consists of selecting two surfaces at a time. The first assembly constraint in this case would require us to select the cylinder of the peg and the inside cylinder of the hole. PTC Creo interprets the selection of those two surfaces as a coincident constraint and aligns the axes.

The second assembly constraint would involve selecting the underside of the head of the peg and the top of the block. Once again PTC Creo interprets that to be a coincident constraint and aligns the flat surfaces.

Let’s do this in PTC Creo so you can see it happen.
11. Click [Assemble]:
   - Select `assembly_peg.prt`.
   - Click Open.

12. In the graphics area, click to place the peg above your block as shown.

13. In the ribbon, click the Placement tab to open it.
   
   *The Placement tab documents the constraints as you create them. It also allows you to edit the constraints if you want to change them.*

The next step is to select the two appropriate surfaces to create a constraint. PTC Creo helps you by highlighting the surfaces your cursor is on so that you know what surface you would select if you were to left-click.
It is important to note that each click of the mouse tells PTC Creo to use a new surface to make a constraint. **You need to be careful not to click unnecessarily.** Only click to select the appropriate two surfaces.

14. If necessary, zoom in on the peg.

15. Place your cursor on the cylinder of the peg and left-click once to select it as shown.

16. Hold **SHIFT**, middle-click, and drag to pan your model until you can see your block.

17. Place your cursor on the blue cylindrical surface of the block and left-click once to select it.

*You will notice that the axes align automatically.*
Notice that there is now a coincident constraint under the Placement tab with two surfaces listed underneath it.

Also notice that four of the degrees of freedom have been grayed out, indicating that there are only two degrees left: up and down (the green arrow), and rotation (the green arc).

18. Middle-click and drag to rotate your model so you can see the underside of the peg.

19. Left-click on the flat bottom surface to select it.
20. Rotate your model again so you can see the top of the block.

21. Left-click on the top yellow surface to select it.

Notice that initially PTC Creo defines a Distance constraint between the peg and the block. We need a Coincident constraint.

22. Under the Placement tab, open the drop-down menu next to Distance and select Coincident.
23. Click **Complete Component**.

Congratulations! You have successfully assembled your first two parts.

Assembly models are created by assembling each part one at a time until the complete product model is constructed. If we know ahead of time how parts will interact, we can set up prearranged constraints so that the assembly process is easier. In the case of the peg and the block, the selection of the cylindrical surface of the peg and the flat underside of the top of the peg can be automatically predefined so that as you assemble the peg you only need to click on the blue cylinder of the hole and the yellow flat surface of the block. We'll show you how this is done with a new assembly model.
Also, there are other types of constraints that we can use when assembling to allow parts to move with respect to each other. These new types of constraints are called kinematic constraints. So let’s try a little more complicated model.

1. From the Quick Access Toolbar, click **Close** to close the Peg Assembly.

2. From the **Home** tab, **Data** group, click **Erase Not Displayed**.

3. Click **OK** to clear the session from memory.

4. From the **Home** tab, **Data** group, click **Select Working Directory**.

5. Navigate to the **How to Model Almost Anything** folder:
   - Double-click the **Lego_Truck** folder.
   - Click **OK**.
6. From the **Home** tab, click **Open**:
   - Select `truck_top_level.asm`
   - Click **Open**

7. Click **Assemble**:
   - Select `front_wheel.asm`
   - Click **Open**

8. In the graphics area, click to place the wheel near the truck as shown.

   *Notice that there are two constraints that have been predefined. This means that you just need to choose the corresponding surfaces to place the wheel.*

9. If necessary, zoom in on the front axle.

10. Left-click on the blue cylinder of the axle.

11. Left-click on the yellow base of the axle.
The wheel is now assembled in the right orientation.

12. Click Complete Component.

13. On your keyboard, hold down **CTRL + ALT** and left-click and drag the wheel to spin it.

*The wheel spins around the axle because we used a kinematic constraint when we assembled it.*
There are still a few parts missing from the truck, let’s finish assembling them now.

14. Click 🔄 Assemble:
   - Select `engine_cover.asm`.
   - Click Open.

15. In the graphics area, click to place the engine cover near the truck as shown.

When you constrain a part with a curved surface (such as putting on the wheels) the first step is to align the two axis’s. The alignment of these axis constrains two of the translation axis and two of the rotation axis. This eliminates 4 of the 6 degrees of freedom. Usually you only need to constrain 2 more surfaces before the part is fully constrained.

When you are constraining a part with a flat surface (such as placing bricks on top of each other) you must apply an additional constraint. The alignment of flat surfaces only constrains 1 translation axis and 1 rotational axis. This only eliminates 2 of the 4 degrees of freedom. To finish the constraint we will need to apply 3 total constraints which pair up 6 surfaces.
Again we have applied the constraints on part for you. You just need to click on the surfaces on the assembly to complete the placement.

16. Click the blue surface first, the yellow surface second, and the green surface third.

The engine cover is now assembled in the right orientation.

17. Click Complete Component.

18. Using what you have learned, finish assembling the trucking by putting on two front_light.prt.

If you are having trouble, refer back to steps 7-12.
Congratulations, you have finished assembling the Lego Truck!

Review

Let's review what we have been able to do in PTC Creo to this point:

1. Creating a new assembly (Step 4)
2. Assembling to first part into an assembly (Step 6-10)
3. Using the default constraint (Step 9)
4. Assembling a static component into an assembly (Step 11-23)
5. Defining a coincident constraint (Step 14-17)
6. Modifying a constraint type (Step 22)

Now that you have had a chance to practice each of the steps in the PTC Creo, try answering these questions:

1. What are constraints and how are parts assembled in PTC Creo Parametric?
2. What are degrees of freedom? How many are there?
3. How do you know if a degree of freedom has been constrained?
4. What do you always do to the first part in an assembly?
5. How do you make an assembly constraint? What do you click on?
6. What do we call a constraint that allows parts to move with respect to each other?
Practice Exercise

Let’s see if you can use the skills learned thus far to put together the glider model from Exercise 1.

1. Set your working directory to the Glider_Assembly folder.

2. Click New.
   - Change type to Assembly.
   - Type “Glider_top_level” as the name.

3. Assemble fuselage_assembly.asm with a default constraint

   If you are having trouble, refer back to steps 7-10 of the peg and block activity.
4. Assemble `wing_left.asm`, `wing_right.asm`, and `tail.asm` to the glider.

   **Assemble by clicking the blue, yellow and then green surfaces.**

   *If you are having trouble, refer back to steps 14-17 of the Lego truck activity.*

5. When you have finished assembling the parts you should have a completed glider!

---

**FINAL ASSESSMENT**

Begin by opening the Mars rover model in PTC Creo Parametric and follow the instructions here:

1. Open `mars_rover.asm` (Located in the Mars_Rover folder of How to Model Almost Anything) in PTC Creo Parametric.
2. Assemble the antenna *(antenna.prt)* to the rear left hole of the rover.

3. Assemble the Radar Subassembly *(radar_subassembly.asm)* to the rear right hole of the rover.

4. Assemble the Eye Pole Subassembly *(eye_pole_subassembly.asm)* to the front hole of the rover.

*Congratulations! You have completed this exercise.*
Exercise 5

Assembling Systems
Sub-assemblies & Product Models

CREATING SUBASSEMBLIES AND FULL PRODUCT MODELS

Creating Sub-assemblies
An important part of modeling products is to determine the sub-systems that make up the product and the corresponding sub-assembly models. This can often be represented using tree graphs.

Here is an example tree graph of the DaVinci Ornithopter showing the various sub-systems that make up the product. Each of the sub-systems can be modeled as a separate assembly model within PTC Creo.
Let’s begin by examining a toy car product model and dividing it up into its appropriate sub-assemblies.

Consider a toy car model as shown in its exploded state. What parts should be grouped into sub-systems?

![Diagram of a toy car model in exploded view]

Each wheel and tire could be a sub-system and then two wheel-tire sub-systems connected to an axle could be another sub-system. The chassis with two of the wheel-tire-axle sub-systems could be another sub-system. Finally, the windows could be grouped with the car body to create a sub-system. The final assembly could then just be assembling the chassis sub-system with the motor mechanism and the car body sub-system.
If we create an assembly file for each of the sub-systems, our product model will match our sub-system strategy. So let’s begin.

1. **Start PTC Creo Parametric** by double-clicking on the icon or by going to the Start Menu, finding **PTC Creo Parametric**, and selecting it.
2. From the **Home** tab, **Data** group, click **Select Working Directory**.

   *Remember that this allows you to set the folder that PTC Creo Parametric will use to open and save files.*

3. Navigate to the **How to Model Almost Anything** folder.
   - Double-click the **Car** folder.
   - Click **OK**.

4. From the **Home** tab, click **New**.
   - Change the type of file to **Assembly**.
   - Type in "**Wheel_Subsystem**" for the file name.
   - Click **OK**.
5. From the In Graphics toolbar:

- Click **Datum Display Filters** and disable the display of all datum features.

6. From the **Schools** tab, **Assembly** group, click **Assemble**.

7. Select **Wheel.prt** and click **Open**.

   *The part will follow your cursor until you left-click to drop it in the Graphics Area.*

8. Left-click anywhere in the Graphics Area to drop the part.

   *The Orientation Sphere helps you reposition a part once you have dropped it.*
The first part in an assembly doesn’t have any other parts to reference, so it needs to be locked to the origin.


Default locks the model to the origin.

Notice that the part has changed color, the orientation sphere has disappeared, and it has the “STATUS” of Fully Constrained.

10. Click The green check mark ✅.
Now that the wheel is in place, let’s add the tire to it. We will need two constraints to align the tire to the wheel. The first constraint will be to align the axes of each and the second will be to align the edge of the wheel to the edge of the tire.

11. Click **Assemble**:
   - Select **Tire.prt**.
   - Click **Open**.

12. In the graphics area, click to place the tire next to the wheel as shown.

13. In the ribbon, click the **Placement** tab to open it.

   *The Placement tab documents the constraints as you create them. It also allows you to edit the constraints if you want to change them.*
Since there are no predefined constraints in this model, you will need to select two surfaces to define each of the constraints. To begin let's select two cylindrical surfaces to align the axes of the tire with the wheel.

14. If necessary, zoom in on the tire.

15. Place your cursor on the cylindrical surface on the inside of the tire, and left click as shown.

You may find it easier to see component in separate window. This will open a new smaller window with only the component that will be easier to see and manipulate. There is also a way of showing the new component only in this window, not in the main window.
16. Hold **SHIFT**, middle-click, and drag to pan your model until you can see the wheel.

17. Place your cursor on the cylindrical surface of the wheel and left-click once to select it.

You will notice that the axes align automatically.

Notice that there is now a coincident constraint under the Placement tab with two surfaces listed underneath it.
Also notice that four of the degrees of freedom have been grayed out, indicating that there are only two degrees left: up and down (the red arrow), and rotation (the red arc).

18. Middle-click and drag to rotate your model so you can see the side of the tire with a larger opening.

19. Place your mouse on the inside flat surface of the tire and left click to select.
20. Rotate your model again so you can see the inside surface of the wheel.

21. Left-click on the rim surface that is colored blue to select it.

22. Depending on how you have arranged the wheel and tire PTC Creo will most likely create a distance constraint.

Under the Placement tab or in the dashboard open the drop-down menu next to Distance and select **Coincident**.

If, by mistake, you made an unwanted select of a surface you may right-click on it and chose **Remove**.
Your wheel-tire assembly should look like this. The **Flip** option allows you to change the orientation of flat surface constraints since there are two possible options for each flat surface constraint.

23. Click green check mark.

24. Now save this sub-assembly by clicking **Save** under the **File** menu and then click **OK** in the dialog box.

25. Finish by selecting **Close** under the **File** menu.
Congratulations! You have successfully created your first sub-assembly. Now let’s continue and create the axle sub-assembly.

26. From the **Home** tab, click **New**.
   - Change the type of file to **Assembly**.
   - Type in "**Axle_Subsystem**" for the file name.
   - Click **OK**.

27. From the **Schools** tab, **Assembly** group, click **Assemble**.

28. Select **axle.prt** and click **Open**.
29. Left-click anywhere in the Graphics Area to drop the part.

   *The Orientation Sphere helps you reposition a part once you have dropped it.*

30. From the Automatic pull-down menu, choose Default.

   *Default locks the model to the origin.*

31. Click on the green check mark ✓.

   *Notice that the part has changed color, the orientation sphere has disappeared, and it has the “STATUS” of Fully Constrained.*

Now that the axle is in place, let’s add the wheel sub-system to it. We will again need two constraints to align the axle to the wheel sub-system. The first constraint will be to align the axes of each and the second will be to align the edge of the axle to the inside edge of the wheel subsystem.
32. Click **Assemble**:
   - Select `wheel_subsystem.asm`.
   - Click **Open**.

33. In the graphics area, click to place the wheel sub-assembly next to the axle.

34. In the ribbon, click the **Placement** tab to open it.

   The **Placement** tab documents the constraints as you create them. It also allows you to edit the constraints if you want to change them.

Since there are no predefined constraints again in this model, you will need to select two surfaces to define each of the constraints. To begin let’s select two cylindrical surfaces to align the axes of the wheel sub-assembly with the axle.

35. Place your cursor on the cylindrical surface inside the wheel sub-assembly and left-click once to select it as shown.

   The surface numbers (Surf:F10(EXTRUDE_3)) may not match your model and that is OK. Just find the right surface visually and select it.
36. Place your cursor on the cylindrical surface of the axle and left-click once to select it.

*You will notice that the axes align automatically.*

37. If necessary, left click and drag the blue arrow in the orientation sphere to move the wheel off the axle as shown.
In order to change the highlighted surface you may right-click on it. This way you may select a surface from behind the surface highlighted. You also may long right-click on a surface to get the menu with next/previews/pick from list options in order to select the wanted surface of a complex model.

38. Rotate and zoom to select the inner flat surface of the wheel as shown.
39. Middle-click and drag to rotate your model so you can see the end of the axle.

40. Place your mouse on the flat end and left-click to select it.

41. Change the distance constraint to coincident using the pull down menu in the Placement tab.

42. Click on the green check mark ✅.

43. Repeat this procedure to place a second wheel sub-assembly on the other side of the axle.

44. Because PTC Creo remembers how you constrained the first wheel sub-assembly, you will only need to select the axle cylinder and the end of the axle.

*You may have to Flip the second constraint to make sure the wheel is oriented correctly.*
45. Now save this sub-assembly by clicking **Save** under the **File** menu and then click **OK** in the dialog box.

Now that we have completed the axle sub-assembly, let’s move on to the chassis sub-assembly. Notice that because we created the wheel sub-assembly when we constructed the axle sub-assembly we could use the wheel sub-assembly twice. We will do the same thing when we create the chassis sub-assembly.

46. From the **Home** tab, click **New** :
   - Change the type of file to **Assembly**.
   - Type in "**Chassis_Subsystem**" for the file name.
   - Click **OK**.
47. From the **Schools** tab, **Assembly** group, click **Assemble**.

48. Select **chassis.prt** and click **Open**.

The part will follow your cursor until you left-click to drop it in the Graphics Area.

49. Left-click anywhere in the Graphics Area to drop the part.

*The Orientation Sphere helps you reposition a part once you have dropped it.*
50. From the **Automatic** pull-down menu, choose **Default**.

*Remember that Default locks the model to the origin.*

Notice that the part has changed color, the orientation sphere has disappeared, and it has the “STATUS” of **Fully Constrained**.

51. Click the green check mark ✅.

The surfaces you will need to use in assembling the axle sub-systems to the chassis have been highlighted with yellow and blue colors. Because you want the wheels and axles to spin in the chassis you will need to use a kinematic constraint called a “Pin” joint. A pin joint is similar to the constraints you have been using. It is found under the User Defined pull down menu in the assembly dashboard. Let’s walk through the first axle placement and then you can do the second one.
52. Click Assemble:
   - Select axle_subsystem.asm.
   - Click Open.

53. In the Graphics area, left click to place the axle sub-assembly next to the chassis.

54. In the ribbon, click the Placement tab to open it.

Because we want the axles to spin, we will use the Pin constraint under the User Defined pull down menu.

55. Open the pull down menu under User Defined and select Pin.
56. Place your cursor on the cylindrical surface of the axle and left-click once to select it as shown.

57. Place your cursor on the cylindrical surface of the groove in the chassis and left-click once to select it.

*You will notice that the axes align automatically.*
58. Select the surface inside the wheel.

59. Rotate and zoom so that you can see and select the flat surface on the side of the chassis as shown.
60. Change the Coincident constraint to a **Distance** constraint.

61. Set the **Offset value** to **.125** and then press Enter.

62. Click the green check mark ✓.

63. Test to see that the wheels spin by pressing and holding **CTRL-ALT** and left-clicking and dragging on the wheels to spin them.

64. Repeat this procedure to place a second axle sub-assembly on the other side of the chassis.

   *Because PTC Creo remembers how you constrained the first axle sub-assembly, you will only need to select the yellow groove and the blue side of the chassis.*
65. Now save this sub-assembly by clicking **Save** under the **File** menu and then click **OK** in the dialog box.

66. Finish by selecting **Close** under the **File** menu.

When you save this sub-assembly PTC Creo may warn you that the model is not regenerated. This is because of the kinematic constraints. Regenerating the model will place the wheels back in the original position. Since this is not important for this model, just click **OK**.

Now we have created three sub-assemblies; the wheel sub-system, the axle sub-system, and the chassis sub-system. We need to build one more sub-system, the car body and windows sub-system, before we can assemble the complete product assembly model.

67. From the Home tab, click **New**:

- Change the type of file to **Assembly**.
- Type in **"Body_Windows_Subsystem"** for the file name.
- Click **OK**.
68. From the **Schools** tab, select the **Assembly** group, click **Assemble**.

69. Select **body.prt** and click **Open**.

70. Left-click anywhere in the Graphics Area to drop the part.
71. From the **Automatic** pull-down menu, choose **Default**.

Notice that the part has changed color, the orientation sphere has disappeared, and it has the “STATUS” of Fully Constrained.

72. Click the green check mark ✓.

73. Click **Assemble**:
   - Select **Windows.prt**.
   - Click **Open**.

74. In the Graphics area, click to place the windows part next to the body.
The windows were designed based on the car body, so they can also be assembled using a Default constraint.

75. From the **Automatic** pull-down menu, choose **Default**.

76. Click the check mark to finish placing the windows in the assembly.

77. Now save this sub-assembly by clicking **Save** under the **File** menu and then click **OK** in the dialog box.

78. Finish by selecting **Close** under the **File** menu.
We are now ready to assemble the final product model. All of the subsystems are modeled and we can assemble the complete product.

79. From the **Home** tab, click **New**.
   - Change the type of file to **Assembly**.
   - Type in “**Red_Car**” for the file name.
   - Click **OK**.

80. From the **Schools** tab, **Assembly** group, click **Assemble**.

81. Select **chassis_subsystem.asm** and click **Open**.
82. Left-click anywhere in the Graphics Area to drop the part.

83. From the **Automatic** pull-down menu, choose **Default**.

84. Click the green check mark ✓.

Now let’s put the motor mechanism in place in the chassis.
85. Click Assemble:
   - Select gearbox_sub.asm.
   - Click Open.

86. In the Graphics area, click to place the motor mechanism sub-assembly next to the chassis.

87. Select the side of the motor mechanism.

88. Now select the blue surface inside of the motor mount on the chassis as shown.
89. Select the back of the motor mechanism.

90. Select the green surface inside the motor mount.
91. Select the bottom of the motor mechanism.

92. Select the yellow surface inside the motor mount.

   You may need to change from a Distance constraint to a Coincident constraint.

93. Click the green check mark ✅.
94. Click Assemble:

- Select `car_body_windows_subsystem.asm`.
- Click Open.

95. In the Graphics Area, click to place the car body windows sub-assembly next to the chassis.

96. Rotate the car body so that you can see underneath and select the inside of the hole on the front of the car body as shown.

97. Now select the blue cylindrical surface of the front peg on the chassis.
98. Repeat step 96 with the hole located at the rear of the car body.

99. Select the blue cylindrical surface of the rear peg on the chassis.

   Make sure that the constraint is a Coincident constraint.
100. For the final constraint, select the top surface of the hole located in the front of the body as shown.

101. Select the top of the round post in the front of the chassis as shown.

*Make sure that the constraint is a Coincident constraint.*
102. Click the green check mark ✔.

103. You can see all of the parts in the product model by selecting **Exploded View** from the **Model** tab in the upper menu.

104. You can also see the assembly references in the form of a tree by clicking on **Reference Viewer** on the far right of the **Model** tab and then select **Dependencies**.

   This is a way of understanding assemblies and sub-assemblies.
105. Now save this final assembly model by clicking **Save** under the **File** menu and then click **OK** in the dialog box.

106. Finish by selecting **Close** under the **File** menu and **Erase Not Displayed**.

**Review**

The assembly modeling that you have completed may seem a little tedious but by following these methods you can create models of products more efficiently. So let’s review what we have been able to do in PTC Creo:

1. How to divide a product into its sub-systems and appropriate sub-assemblies (Pages 2-4)
2. Create a sub-assembly model and save it (Steps 1-25)
3. Create multiple sub-assembly models (Steps 26-78)
4. Create a final product model using the sub-assemblies you created earlier (Steps 79-102)
5. Exploded the final assembly (Step 103)
6. Explored the dependency tree (Step 104)

This method of creating sub-assemblies before creating the final product model saves time and organizes your models.

**Practice Exercise**

So let’s try each of these actions again but with a new model.
This is the model of a proposed nano-probe that would be used to do cell repair in the human body. This system is different than the red car. It has sub-systems but all of the subsystems are single parts that do not reference each other. For example notice the yellow pumps. There are 12 of them and together they form a subsystem within the nano-probe, however they all assemble independently into the shell of the nano-probe so rather than create a sub-assembly model with just the pumps, we will assemble them in the top level product model and then group them into a subsystem. We will take this same approach with the red sensors and green sensors. This will allow us also to explore using patterns to assemble parts. Let’s get started.
1. Set your **working directory** to the **Nano Probe** folder in the How To Model Almost Anything Folder and then create a **New** assembly called "Nanoprobe_product_model".

   *If you need help remembering how to create a new assembly file look at step 4.*

2. Assemble the **Nano_sphere** component into the assembly file and apply the **Default** constraint.

   *Refer to Steps 6-10.*
3. Insert the red acoustic relay using the constraints shown.

4. Insert a single pump using the constraints shown.

5. Now left click to select the pump in the model tree on the left and then select Pattern in the Model tab.
6. Change the Reference pull down menu to Axis.

7. Left click to select the Z-AXIS.

You will have to turn on the datum display in order to select the Z-AXIS. This will be attached to the coordinate system in the center of the model.
8. Change the number of instances to 6 and then click the 360 degree tool.

   *You will see 6 dots indicating where the pumps will be assembled.*

9. Now click the check mark to finish the patterned assembly.

10. Repeat steps 5-9 for the next row of pumps.

   *The distance offset for the constraint is .375.*
11. Hold **CTRL** and left-click on the two patterns in the model tree.  
12. Right-click and select **Group**.

13. Right-click on your new Group and select **Rename**. Type "**Pump_subsystem**" and press **ENTER**.

   Notice that now you have a group for the pumps, when you hover over it in the model tree it highlights all of the pumps. In this way you have created a subsystem.
14. Next, assemble the green sensor in the same way and pattern it to create 8.

15. Now repeat this to assemble the red sensor.

16. Finally assemble the inner probe as shown.
17. You can edit and change constraints by right clicking in the model tree on the part or sub-assembly you wish to change and selecting **Edit Definition**.

18. Then open the **Placement** tab and click on the constraint you wish to edit. There will be two surfaces associated with each constraint. You can right click and select **Remove** to select a new surface or right click on the constraint and select **Delete** to eliminate the constraint all together.

19. Finish by saving your assembly.
Now that you have had a chance to practice each of the steps in the Nanoprobe exercise, try answering these questions:

1. What are constraints and how are parts assembled in PTC Creo Parametric?
2. Name two ways to create subsystem models in PTC Creo?
3. Can you create a constraint between a face of a part and one of the datum planes?
4. What is a pattern used for when assembling?
5. How do you edit and change constraints once they have been made?
6. Can you assemble the same sub-assembly multiple times within a product assembly?
FINAL ASSESSMENT

Complete the Prosthetic Hand exercise and submit the final assembly model. Begin by setting your working directory to the Prosthetic Hand folder and follow the instructions here:

1: Open the Prosthetic Hand model and study it to decide how you are going to create the subsystems.

2: When you create the fingers and other joints make sure you use kinematic constraints so that they all move.
3: Make sure to place limits on the motion of the pin joints by selecting the Rotation axis constraint in the Placement tab.

3a: Now select two flat surfaces that will define the rotation of the parts.
3b: You can now define the zero position, enable it as the regeneration value, and set the min and max limits.

4: Finish assembling the prosthetic hand. This is a project that can be 3D printed and assembled for real as a prosthetic assistance.

Congratulations! You have completed this exercise.
Mechanisms

Using Kinematic Joints to Create Mechanisms

What is a Mechanism?

A mechanism is created when multiple kinematic elements are combined to create a machine that provides some desired motion or mechanical advantage. In the diagram below, you can see multiple kinematic elements that have been combined to create a crank and slider mechanism. This mechanism converts rotary motion into linear motion with a slight mechanical advantage.

Since it is possible to create kinematic joints in PTC Creo, mechanisms can be created by combining multiple joints. There is a specific application within PTC Creo dedicated to creating mechanisms.
Let’s begin by creating a drivetrain for a small robot and defining gear pairs so that the wheels will turn appropriately.

1. Start **PTC Creo Parametric** by double-clicking on the icon or by going to the Start Menu, finding **PTC Creo Parametric**, and selecting it.

2. From the **Home** tab, **Data** group, click **Select Working Directory**.

   *Remember that this allows you to set the folder that PTC Creo Parametric will use to open and save files.*

3. Navigate to the **How to Model Almost Anything** folder:
   - Double-click the **Drivetrain** folder.
   - Click **OK**.
4. From the **Home** tab, click **New**:
   - Change the type of file to **Assembly**.
   - Type in "**Mydrivetrain**" for the file name.

5. Click **OK**.

6. From the In Graphics toolbar:
   - Click **Datum Display Filters** and disable the display of all datum features.

7. From the **Schools** tab, **Assembly** group, click **Assemble**.

8. Select **channel-288mm.prt** and click **Open**.
9. Left-click anywhere in the Graphics Area to drop the part. *The Orientation Sphere helps you reposition a part once you have dropped it.*

10. From the **Automatic** pull-down menu, choose **Default**.

11. Click the **green checkmark** to complete placing the component.

12. Now that the channel is in place, assemble a bronze bushing (**axle-bronze_bushing.prt**) for the axle using two coincident constraints into the middle hole in the channel.
13. From the Model Tree, right-click AXLE-BRONZE_BUSHING.PRT and select Repeat from the pop-up menu.

14. In the Repeat Component dialog box, hold CTRL and left-click on the two Coincident constraints.

15. Click Add.
16. Left-click on the inner surface of a hole that is 5 spaces away from the middle as shown.

17. Left-click on the side of the channel to complete the placement of the bushing.

18. Place 4 more bushings in the channel to match the image to the right.

   You’ll have to rotate and zoom the model to place the bushings on the opposite side.

19. In the Repeat Component dialog box, click OK to add the bushings to the assembly
20. Bring `large_gear_sub.asm` into the assembly and drop it next to the channel.

21. From the User Defined drop-down menu, select **Pin**.

   *A pin constraint will allow the gear to spin in the hole.*

22. Use your knowledge of Pin constraints to assemble the gear into the middle set of bushings as shown.

   *Make sure the spacer on the back of the gear is coincident to the face of the bushing.*
23. Use two more Pin constraints to add the wheels (wheel_large-sub.asm) on either side of the gear.

24. Rotate your assembly so that you can see the gear teeth.

25. Use the CTRL + ALT keys to rotate the two outer wheels and ensure the gears mesh correctly.

Now we will move into a new application of PTC Creo called “Mechanism”. This area of PTC Creo provides tools for creating and simulating mechanisms.

26. From the Schools tab, click Mechanism.

27. From the Mechanism tab, select Gears.
A gear pair tells PTC Creo that two pin joints are connected in a specific way. Typically, this relationship is defined by a ratio. For example, when two gears connect, there is a gear ratio that relates the diameters of the two gears or the number of teeth on each gear.

28. Left-click on the orange motion axis of the large gear.

29. From the Gear Pair Definition dialog box, select the Gear2 tab.

30. Left-click on one of the orange motion axes of the wheels.
31. Select the **Properties** tab.

32. From the **Gear Ratio** pull-down menu, select **User defined**.

33. Set the ratio to **120:80** based upon the number of teeth of the two gears.

34. Click **OK**.

35. Repeat steps 27-34 to create a gear pair between the large gear and the other wheel.

   *You can test the gear pairs by holding the CTRL + ALT keys, left-clicking on one of the wheels, and turning it to see that everything rotates correctly.*
If the rotation is not correct, you may have to flip the direction of the gear pair.

36. If necessary, expand Connections in the Mechanism Tree.

37. Expand Gears, right-click on the appropriate Gearpair, and select Edit definition.

38. In the Gear Pair Definition dialog box, click on the Gear2 tab and use the Flip tool to change the direction of the gear pair.

39. Select File>Save to save your model.

40. From the Schools tab, click Close to close the Drivetrain.

41. From the Home tab, Data group, click Erase Not Displayed. Click OK to clear the session from memory.

Congratulations! You have successfully created your first mechanism.
**Review**

So far you have been able to create a drivetrain for a simple robot that uses gear pairs between multiple pin joints to simulate rotary motion. Let’s review what operations you used:

1. Assembling using the Repeat tool (Steps 13-19)
2. Assembling with pin joints (Steps 20-23)
3. Aligning the teeth on gears (Steps 24-25)
4. Entering the Mechanism application (Step 26)
5. Creating gear pairs (Steps 27-35)
6. Changing the direction of a gear pair (Steps 36-38)

Using these methods you can create drivetrains and geartrains for use in mechanisms and machines of all types.

**Practice Exercise**

Let’s try each of these actions again but with a new model.

This is the model of a pneumatic gear train for a dentist’s drill. There is a small turbine in the rear of the geartrain that powers the sun gear. The
planet gears then transfer the rotation to the ring gear, which holds the Dentist’s drill.

Let’s get started building this planetary geartrain.

1. Set your working directory to the Pneumatic Drill folder in the How to Model Almost Anything folder.

2. Create a new assembly called “PlanetaryGearSystem”.

   If you need help remembering how to create a new assembly file look at step 2.
3. Assemble the **Gear_frame** component into the assembly file and apply the **Default** constraint.

4. Insert the **axle.prt** using a **pin** constraint to the center of the gear frame.
5. Assemble the 80 tooth sun gear (sun_gear_80t.prt) to the axle using static constraints.

   *Use a regular coincident constraint between two sides of the hexagon center and a third between the top surface of the gear and the top of the axle.*

6. Add the three planetary gears (planet_gear_40t.prt) to the posts on the gear frame. Use pin constraints to make sure the gears turn.
7. Now add the ring gear by assembling it with a pin constraint to the gear frame and in alignment with the other gears.

*You can create the axis alignment of a pin constraint by surfaces on the edge of two circular bodies. The axes will be aligned based on the center point of those circles.*

8. Now use the **CTRL-ALT** keys to align all of the gears.

9. Then enter the **Mechanism** application.
10. Create the appropriate gear pairs to connect all of the gears. You may have to flip gear pair connections to make sure all of the gears turn correctly

The sun gear has 80 teeth, the planet gear has 40 teeth and the ring gear has 160 teeth.

Now that you have had a chance to practice each of the steps in the gear train exercise, try answering these questions:

1. What are gear pairs used for in creating a mechanism?
2. What happens if you forget to ground the first part in an assembly with a default constraint?
3. How do you flip the direction of a gear pair?
4. Can you connect more than two gears in a gear pair?
5. What if you have 3 gears in a planetary gear system that you want to connect?
6. How do you calculate the mechanical advantage in a gear pair?
FINAL ASSESSMENT

Set your working directory to the **Lego_Actuator** folder and follow the instructions here:

1. Create a new assembly file called:  
   “MyLego_mechanism”

2. You will need to assemble the Lego parts using 3 coincident constraints which align the flat faces of the parts.
3. Using what you have learned about mechanisms recreate the Lego mechanism.

4. If you need a reference, open `actuator_example_top_level.asm`.

In order to create this mechanism you will need to create a second set of constrains for the **Axle_3** or for the **Beam_15**.
To create the second set of constrains press **New Set** in Placement window.

5. You will also need to use a new kinematic constraint called a “slider” constraint. This constraint requires that you specify an edge along which the part will slide and then two faces that will slide upon each other.
6. To set up the Axis alignment, select slider from the kinematic constraints list.

7. To set up the Axis alignment, select the edge of the beam and the edge of the sbeam.
8. To set up the Rotation, select the side surface of the sbeam and the side surface of the beam.

9. Finish assembling the Lego mechanism.

Congratulations! You have completed this exercise.
Exercise 7

Concept Development

Chocolate filling

Hard candy shell

Easter colors

Chocolate covered almond inside the chocolate filling
Custom Part Creation

DESIGNING AND CREATING NEW PART GEOMETRY

Designing a New Product
Designing a new product is exciting because it allows you to be creative. In this section we will explore how to make new parts using solid modeling techniques.

We’ll start by assuming that you are a design engineer for a candy company and you have been tasked with creating and launching a new candy product line for your company. You will need to follow a product development process to come up with a new product. This will include doing the following:

1. A quick market analysis,
2. Brainstorming several new ideas,
3. Developing 2-3 of your ideas into conceptual designs by creating solid models.

Challenge: Design a new candy product line inspired by geometric shapes

STEP 1: A QUICK MARKET ANALYSIS
The first step in this process will be to explore the market place to determine what group of people you will want to focus on. Second, you will need to explore different types of candy and explore the geometric shapes that could inspire your design and that your company can manufacture.
There are many different potential market segments for your new candy. You will want to select one market to focus your design on. Here are several:

1. Young children
2. Athletes
3. Professionals
4. Seniors
5. Family’s traveling
6. Teenagers
7. Sports fans

Select one of these or other market segments for your focus group. Once you have decided on the market, you can then begin considering the type of candy you will create:

1. Chocolate
2. Mint
3. Caramel dipped in chocolate
4. Nuts dipped in a hard candy coating
5. Etc.

Now consider some geometric shapes and colors to inspire your candy design. Here are some example shapes:

![Geometric shapes](image)

While you are considering the shape of your new candy, you need to make sure that the basic shape you select is on the list of your
manufacturing group’s candy molds. Here is a list of the shapes that your manufacturing group can create:

**STEP 2: BRAINSTORMING**

You will want to do some brainstorming to generate ideas and sketch them to capture and document these ideas. The more ideas you create the more likely you will come up with a real winner. Generate at least 6-7 or more ideas. Usually companies spend a great deal of time brainstorming ideas for a new product. Spend a little time right now sketching out your ideas.

**STEP 3: DEVELOPING CONCEPTUAL DESIGNS**

Now you need to select your best 2-3 ideas and convert them into conceptual designs. We will use solid modeling, which is the language of product development to convert your ideas into conceptual designs.
Solid models are created using four basic operations:

**Extrude** is taking a cross-section and extending it in a straight line into 3D as shown.

![Extrude Diagram]

**Revolve** is taking the cross-section and revolving it about an axis as shown.

![Revolve Diagram]

**Sweep** is taking the cross-section and sweeping it along a curve as shown.

![Sweep Diagram]
**Blend** is taking two or more cross-sections and blending between them along a curve.

Using these four operations it is possible to construct almost all types of solid models.

For the candy exercise you will want to use an extrude. Let’s create a new part for your candy design and use an extrude to make it into a solid model.

1. Start **PTC Creo Parametric** by double clicking on the icon or by going to the Start Menu, finding **PTC Creo Parametric**, and selecting it.

2. From the **Home** tab, **Data** group, click **Select Working Directory**.

   *Remember that this allows you to set the folder that PTC Creo Parametric will use to open and save files.*
3. Navigate to the **How to Model Almost Anything** folder:
   - Right-click the window and select New Folder.
   - Type **Candy** for the new folder name and then **OK**.
   - Click **OK**.

4. From the **Home** tab, click **New**:
   - Type **"New_Candy"**
   - Click **OK**

*Remember that file names can’t have spaces in them.*
5. From the **Schools** tab, **Features** group, click **Extrude**.

6. Assign a name to this extrude by clicking on the **Properties** tab and entering “**CANDY_BODY**.”

7. Set the thickness of your candy by entering **0.25** in the depth field and pressing **ENTER** on your keyboard.

You need to select a plane upon which to sketch the outline of your candy.

8. In the Graphics Area, left-click on the **Top** plane to select it.

Now that you are in the sketcher within PTC Creo Parametric you can create any closed cross-section using the tools provided. For this exercise, you can use a palette of already created cross-sections to make it easier.
9. From the Sketch tab, click the drop-down menu next to More, then select Palette.

The Sketcher Palette dialog box contains many different shapes you can use to make your cross-section.

For this exercise, let's use a 6-sided Hexagon.

10. Left-click and drag the icon of the hexagon to place it in the Graphics Area.

11. Close the Sketcher Palette dialog box.
12. Left-click and drag the center of the hexagon to center it on the Origin.

13. Double-click the number at the bottom right corner of the hexagon, enter **0.5**, and press **ENTER** on your keyboard. This will set the length of one side.

14. Click **OK** to exit the **Palette** tool.

15. From the In-Graphics Toolbar, click **Refit**. Click **OK** to complete the sketch.
17. Middle-click and drag to rotate your model and see your extrude in 3D.

18. Click ✔️ OK to complete the extrude.

Your candy base is now complete.

Congratulations, you have created your first extrude. There are several other operations that you can use to help customize your creation. Two tools that you can use are Rounds and Chamfers. Rounds are used to round off edges and chamfers are used to cut the edges at an angle.

19. From the Schools tab, Features group, click 🔄 Round.
20. On your keyboard, press **CTRL + D** to return the model to its default orientation.

21. Left-click on one of the top edges of your candy as shown.

22. Left-click and drag on the handles to change the size of the round.

*Notice that two white boxes will now appear. These are called “drag handles”.*
23. Hold **CTRL** and left-click on each remaining top edge to apply the round to them all.

24. Click ✓ **OK** to complete the round.

Now let’s chamfer the bottom of the candy by using the chamfer tool. A chamfer cuts the edges at an angle and gives a very different effect than the round tool.

25. From the **Schools** tab, **Features** group, click **Chamfer**.

26. Left-click on one of the bottom edges of the candy.

27. Use the drag handles to change the size of the chamfer.
28. Hold **CTRL** and select the remaining bottom edges.

29. Click **OK** to complete the chamfer.

Text can also be used as a cross-section for an extrude operation. Each letter must be created as a closed sketch. There is a tool for doing this in the Sketch tab.

30. On your keyboard, press **CTRL + D**.

31. From the **Schools** tab, **Features** group, click **Extrude**.

32. Using the Properties tab, name this extrude "**Text**."

33. Set the depth of the extrude to **0.0625** and press **ENTER**.
34. In the Graphics Area, left-click on the top face of your candy as shown.

35. From the Sketch tab, More group, select Text.

36. Left-click on the origin, move your mouse up to set the text height, and then left-click again.
37. In the Text dialog box, enter your initials or your desired text.

38. From the Horizontal pull-down menu, select Center.

39. From the Vertical pull-down menu, select Middle.

40. Click OK in the Text dialog box.

41. Click ✓ OK to complete the sketch.
Notice that the extrude is too tall for the candy.

42. In the depth field, type .0625/3 and press ENTER.

43. Click ✅ OK to complete the extrude.

44. From the In-Graphics toolbar, Click Datum Display Filters and disable the display of all datum features.

Color plays an important part in all products, particularly candy. PTC Creo Parametric allows you to assign color to the different surfaces in your part. You can see the different surfaces when you have the displayed style set to Shading With Edges because all of the edges of the surfaces are outlined.

You can now use the Render tools to color your candy design.
45. From the **Schools** tab, **Display** group, click the drop-down menu under **Appearance Gallery**.

46. Left-click on a color sphere to select a color.

47. In the Graphics Area, left-click on a surface to select it.

   *Remember that to select multiple surfaces you need to hold down CTRL.*

48. Once you have selected the surfaces, click **OK** to finish.
49. Use the Appearance Gallery to fully color your candy.

50. From the Quick Access Toolbar, click **Save**.

51. In the **Save Object** dialog box, click **OK**.
Documenting your Design in a Product Brief

Now that you have created a design for a new product, you need to document it in a way that communicates the important aspects of the design. One method of doing this is in creating a product brief. A product brief is a one page document that shows different views of the product with notes that highlight the important aspects.

You can use notes and arrows to identify and highlight features of your design. You can also use color to highlight.
Different views also help identify the important aspects of the product. You can create a product view in PTC Creo by creating a new drawing.

52. From the **Schools** tab, **Models** group, click **New**

- Change the Type to **Drawing**
- Enter "**MyCandy_Productbrief**".
- Click **OK**.

53. From the New Drawing dialog box:

- Select **Empty** under **Specify Template**.
- From the drop-down menu next to **Standard Size**, select **A**.
- Click **OK**.

54. From the **Layout** tab, select **General View**.
55. From the Select Combined State dialog box, select **DEFAULT ALL** and click **OK**.

56. Left-click anywhere on the page to place your view.

57. From the Drawing View dialog box, select **Scale** under Categories:
   - Select **Custom scale**.
   - Change the value to **5**.
   - Click **Apply**.
58. From the Drawing View dialog box, select **View Display** under Categories:
   - From the drop-down menu next to Display style, select **Shading With Edges**.
   - Click **OK**.

59. Left-click on the view to select it.

60. Right-click and select **Lock View Movement** from the pop-up menu.
   
   *This will unlock the view so that you can move it.*

61. Left-click and drag the view to any location you want.

62. Repeat steps 3 – 10 to add another view.
   
   *The Drawing View dialog box contains many options for orienting, displaying, and shading your view. Use these options to add a different view of your candy that helps show the features.*
63. From the **Annotate** tab, expand the pull-down menu under **Note**.

*There are several different types of notes that you can create. Note that this is slightly different in Creo 2.0.*

64. Experiment with the notes to add detail to your product brief.

65. Left-click to attach the leader, then middle-click to place the note.

66. Explore different fonts, sketch style lines, and insert pictures or backgrounds to make the product brief as exciting as possible.

67. Once you have finished your product brief, click **Save** from the Quick Access Toolbar.
Review

Now that you have created your first candy model, let’s review the steps and operations you have completed:

1. You selected a market segment after doing a brief market analysis (Page 1-2)
2. You then considered different geometric shapes and sketched some conceptual designs. You selected 2-3 of your best. (Page 2)
3. You learned how to create a folder as your working directory and created a new part model (Steps 1-4)
4. The next step was to create an extrude called Candy_base (Steps 5-8)
5. Next you selected a closed sketch of a hexagon from the Palette tool (Steps 9-18)
6. You added rounds and chamfers to your extrude (Steps 19-29)
7. Next you added text to your candy design (Steps 30-43)
8. You used the Appearance Gallery to add color to your design (Steps 44-51)
9. You created a new drawing (Steps 52-53)
10. You created a product brief (Steps 54-67)

Practice Exercise

1. Use one of your own conceptual designs and what you have learned to create your own candy design.
2. Refer to the steps outlined in the review to help you create your model.
3. Before you begin, make sure you turn the datums back on using the Datum Display menu.
Now that you have had a chance to practice each of the steps in the candy design exercise with your own design, try answering these questions:

1. Why is a market analysis helpful in creating new conceptual designs?
2. Why are sketches helpful in documenting your brainstorming of new ideas?
3. What is an extrude and why do we use it to create geometry?
4. Explain how you used closed sketches and extruded them to create the base of your candy model.
5. How do you add text to a model?
6. What are rounds and chamfers?
7. How do you add color to your models?
8. What is a product brief?
9. How do you create a drawing in PTC Creo?

**FINAL ASSESSMENT**

Use another of your conceptual designs to create a new candy product.

<table>
<thead>
<tr>
<th>1:</th>
<th>What market segment is this candy design focused on?</th>
</tr>
</thead>
<tbody>
<tr>
<td>2:</td>
<td>What geometric shape did you use to create the base shape of the candy?</td>
</tr>
<tr>
<td>3:</td>
<td>Take a screen capture to show the base shape before and after the rounds and chamfers are used.</td>
</tr>
<tr>
<td>4:</td>
<td>Take a screen capture to show your final design.</td>
</tr>
<tr>
<td>5:</td>
<td>Create a product brief and take a screen capture of it.</td>
</tr>
</tbody>
</table>

**Congratulations! You have completed this exercise.**
Custom Part Creation

DESIGNING AND CREATING NEW PART GEOMETRY

Solid Modeling Operations

In order to create new product concepts it is important to know how to use all of the solid modeling operations for creating volumes. Basic shapes can be created using the four operations of extrude, revolve, sweep, and blend. However some parts are even more free form and require a more general creation operation.

A product design challenge will help to learn these new operations for creating volumes. We will follow a basic process for developing conceptual designs:

1. A quick market analysis,
2. Brainstorming several new ideas,
3. Developing 2-3 of your ideas into conceptual designs by creating solid models.
Challenge: Design a next generation water bottle inspired by nature

STEP 1: A QUICK MARKET ANALYSIS
The first step in this process will be to explore the market to determine what group of people you will want to focus on.

There are many different potential markets for your next generation water bottle. You will want to select one market to focus your design upon. Here are several:

1. Young children
2. Athletes
3. Professionals
4. Seniors
5. Traveling families
6. Teenagers
7. Sports fans

Select one of these or other market segments for your focus group. Once you have decided on the market, you can then begin considering the functionality of the water bottle you will create:

1. Spill-proof
2. Recyclable
3. Durable
4. Multi-functional
5. Etc.

Now consider some of the ways that nature stores water. Consider fruit, vegetables, pools, stems, leaves, etc.

What are all of the methods that are used by nature to store water? Choose one of the methods as your inspiration.
STEP 2: BRAINSTORMING
You will want to do some brainstorming to generate ideas and sketch them to capture and document these ideas. The more ideas you create the more likely you will come up with a real winner. Generate at least 6-7 or more ideas. Usually companies spend a great deal of time brainstorming ideas for a new product. Spend a little time right now sketching out your ideas.

STEP 3: DEVELOPING CONCEPTUAL DESIGNS
We will explore several different methods of creating volumes in PTC Creo to help you create your conceptual design.

**Extrude** is taking a cross-section and extending it in a straight line into 3D as shown.
1. Start **PTC Creo Parametric** by double clicking on the icon or by going to the Start Menu, finding **PTC Creo Parametric**, and selecting it.

2. From the **Home** tab, **Data** group, click **Select Working Directory**.

   *Remember that this allows you to set the folder that PTC Creo Parametric will use to open and save files.*

3. Navigate to the **How To Model Almost Anything** folder:
   - Double-click the **Waterbottle** folder.
   - Click **OK**.
4. From the Home tab, click New

- Type “My_Volumes”.
- Click OK.

*Remember that file names can’t have spaces in them.*

5. From the Schools tab, Features group, click Extrude.

6. Assign a name to this extrude by clicking on the Properties tab and entering “My_Extrude.”

7. Set the thickness of your extrude by entering 2.00 in the depth field and pressing ENTER on your keyboard.
You need to select a plane upon which to sketch the cross-section of your extrude.

8. In the Graphics Area, left-click on the Top plane to select it.

Notice that Creo automatically orients the model into a 2D view to make sketching easier.

9. From the Sketch tab, select Center and Point to use the circle tool.

10. Left-click on the Origin to set the center of your circle.

11. Move your cursor out to set the diameter and left-click again.
12. Middle-click once to exit the circle tool.

13. Change the diameter of the circle by double-clicking the dimension, entering 3, and pressing ENTER.

14. From the In-Graphics Toolbar, click Refit.

15. From the Sketch tab, select Center Rectangle.

16. Left-click on the Origin to set the center of your rectangle.

17. Move your cursor down and right to set the size and left-click again.

18. Middle-click once to exit the rectangle tool.

19. Edit the dimensions to the values shown by double-clicking on them.

Notice that the cross section is no longer shaded. This is because there are overlapping lines. We will need to eliminate the overlapping lines.
20. From the Sketch tab, Editing group, select Delete Segment.

21. Left-click and hold to draw a line over any overlapping lines as shown. 

   Make sure to ONLY draw over the lines shown in green or your sketch won’t be closed.

   You can use the Undo button if needed.

22. Middle-click once to exit the Delete Segment tool.

   The cross-section should be shaded. If it’s not shaded, it means there are still stray lines that need to be deleted. Work until you have a clean shaded cross section as shown.

23. Click OK to complete the sketch.
24. Middle-click and drag to rotate your model and see your extrude in 3D.

25. Click ✓ OK to complete the extrude.

Another operation for creating volumes is the **Revolve**. A revolve is taking a cross-section and revolving it about an axis as shown. Let’s add a revolve to the model we are creating.

26. From the **Schools** tab, **Features** group, select **Revolve**.

27. In the **Properties** tab, change the name to “**My_Revolve**”.

28. In the Graphics Area, left-click on the **FRONT** plane.
We need to create a center line that will act as the axis for the revolve.

29. From the Schools tab, Datum group, select Centerline.

30. Left-click on the blue vertical reference line.

31. Move your cursor down so that the centerline is vertical and left-click again.

32. Middle-click once to exit the centerline tool.

The Creo Sketcher allows you to create reference lines based on the features in your model.

33. From the Sketch tab, Setup group, click References.

34. Left-click the top edge of the extrude to select it.

35. Left-click the inner right edge as shown to select it.

36. In the References dialog box, click Close.
37. From the **Sketch** tab, expand the pull-down menu under **More** and select **3-Point/Tangent End Arc**.

38. Move your cursor up and look for the vertical green lines (that show that the elements are on the same vertical) and left-click to place the starting point.

39. Left-click at the intersection of your two new references to place the end point.

40. Move your cursor right and left-click to set the radius of the arc.
41. Middle-click once to exit the arc tool.

42. Double-click on the dimensions to change them to the values shown.

   *Note that it might be necessary to change the radius first, then the distance.*

43. From the **Sketch** tab, select **Line Chain**.

44. Left-click on the top point of the arc to start a line chain.

45. Move your cursor left and left-click on the vertical axis to set the horizontal line as shown.
46. Continue making lines to close the sketch as shown.

47. Once you have finished making lines, middle-click to exit the line tool.

   *Your sketch should now appear shaded in. If it’s not shaded, make sure you have drawn all of the lines shown and your sketch is closed.*

48. Click ✓ **OK** to complete the sketch.

49. Middle-click and drag to rotate your model and see your feature in 3D.

50. Click ✓ **OK** to complete the revolve.
Let's try a new operation to create volume. A **Sweep** is taking a cross-section and sweeping it along a curve as shown below.

*The first step for a sweep is to define the trajectory.*

51. From the **Schools** tab, **Features** group, select **Sketch**.

52. In the Graphics Area, left-click on the **FRONT** plane.

53. In the Sketch dialog box, click **Sketch**.
54. From the **Sketch** tab, expand the pull-down menu under **More** and select **Spline**.

55. Left-click in the model to place the points of your spline and make the shape of your handle.

56. Once you are satisfied with the shape, middle-click to exit the spline tool.

57. Click **OK** to complete the sketch.

58. From the **Schools** tab, **Features** group, select **Sweep**.
59. If necessary, left-click on the spline to select it.

60. From the **Sweep** tab, click **Edit Sweep Section**.

61. Use the circle tool to draw a circle at the origin as shown.

62. Change the diameter to **0.75** and press **ENTER**.

63. Click **OK** to complete the sketch.

Notice that the circle you just made is swept along the spline you created.

64. Click **OK** to complete the sweep.

*If needed you can change one or both 0.000 dimensions to continue the sweep so it enters the volume.*
A fourth operation for creating a volume is called a **blend** and consists of taking two or more cross-sections and blending between them.

65. From the **Schools** tab, **Features** group, click **Blend**.

66. From the **Sections** tab, click **Define**.

*This will allow you to create the first cross-section.*
67. Left-click on the top surface of the revolve as shown.

68. In the Sketch dialog box, click Sketch.

69. From the Sketch tab, Setup group, click References.

70. Left-click on the top circular edge of the revolve as shown.

71. In the References dialog box, click Close.
72. Use the circle tool to create a circle the same size as the reference line you just made.

73. Click ✓ OK to complete the sketch.

74. Middle-click and drag to rotate your model so that you can see the length dimension.

75. Double-click on the dimension, enter **1.00**, and press **ENTER**.

76. From the **Blend** tab, click **Edit Section** to sketch the next cross-section.
77. Use the circle tool to create another circle, slightly offset from the first one. 

_Don’t worry about the dimensions for this section. Just try to get your model to look like the one shown._

78. Click **OK** to complete the sketch.

79. Click **OK** to complete the blend.

_Note that when building blends, the cross sections must have the same number of segments. A rectangle has 4 segments and a circle has 1 segment. If you needed to, you could use the Divide tool to create a 4-segment circle._
80. From the **Schools** tab, **Features** group, click ![Shell](image).

81. In the **Shell** tab, change the **Thickness** to **0.0625**.

82. Left-click on the spout surface shown to remove it.

83. Click ![OK](image) to complete the shell.
There is another option for creating volumes that is more general and is like modeling clay. This operation is called **Freestyle**. It consists of selecting a primitive shape which is like the lump of clay. Then you can select surfaces or edges and push, pull, or twist them to shape the lump of clay. Once the shape is created the primitive can be solidified.

84. From the **Schools** tab, **Features** group, click **Freestyle**.

85. From the **Freestyle** tab, expand the **Primitives** drop-down menu and select the sphere.

86. Left-click and drag to draw a selection box around the lump of clay.

   *This allows you to select the entire primitive volume.*
87. Left-click and drag the arrows to move the lump of clay to the top of the pitcher as shown.

*The primitive you have added to your model is like a lump of clay that can be pushed and pulled to create a unique shape. Notice the box around the primitive. You can select a face, an edge, or a corner of this box and then use the arrow controls to push or pull. You may want to try manipulating the lump of clay to see what is available.*

88. Use the \( \text{\checkmark} \text{ Transform} \) and \( \text{\rightarrow} \text{ Scale} \) tools to shape the lump of clay.

*Note that you can use CTRL to select multiple arrows at the same time.*
89. Once you are satisfied with the shape, orient the lump of clay in the spout of the pitcher.

90. Click ✔️ **OK** to complete the freestyle.

91. From the **Schools** tab, **Features** group, click ![Solidify](image) **Solidify** to make the freestyle solid and join it to the pitcher.

92. Click ✔️ **OK** to complete the solidify.

Using these five operations it is possible to construct almost any type of solid model. The freestyle operation allows for very general shapes while the other four operations provide much more regular and defined shapes.

93. Use the **Round** and **Chamfer** tools to add more detail to your design.

94. Add color to your model using the **Appearance Gallery**.
Review

Now that you have used all five operations to create a part model, let’s review the steps and operations you have completed:

1. You selected a market segment after doing a brief market analysis
2. You then considered different functionality and sketched some conceptual designs. You selected 2-3 of your best.
3. You learned how to create a new part model (Steps 1-4)
4. You created an extrude as a base (Steps 5-25)
5. You created the main body of the water pitcher using a revolve feature (Steps 26-50)
6. You next used a sweep to create a handle (Steps 51-64)
7. Using a blend you were able to create the spout of the water pitcher (Steps 65-79)
8. Used shell to empty the inside of the bottle (Steps 80-83)
9. Finally you used a freestyle feature to create a stopper for the pitcher (Steps 84-92)
10. You then added rounds and chamfers and color to your model to add detail (Steps 93-94)
11. You are ready to use your conceptual ideas to create your new water bottle design.

1. Use one of your own conceptual designs and what you have learned to create your own water bottle design.

2. Refer to the steps outlined in the review to help you create your model.

3. Once you have finished modeling your new water bottle, create a product brief using a new drawing.
Now that you have had a chance to practice each of the steps in the water bottle design exercise with your own design, try answering these questions:

1. Why is a market analysis helpful in creating new conceptual designs?
2. Why are sketches helpful in documenting your brainstorming of new ideas?
3. What is an extrude and why do we use it to create geometry?
4. What is a revolve and why do we use it to create geometry?
5. What is a sweep and why do we use it to create geometry?
6. What is a blend and why do we use it to create geometry?
7. What is a freestyle feature and why do we use it to create geometry?
8. Explain why you need closed sketches to create the various features of your water bottle model.
9. How do you add rounds and chamfers as well as color to your models?
10. Why is a product brief necessary?
**FINAL ASSESSMENT**

Use another of your conceptual designs to create a new water bottle product.

**Step 1:** What market segment is this water bottle design focused on?

**Step 2:** What geometric shapes did you use to create the base shape of the design?

**Step 3:** Take a screen capture to show the creation of each of the shapes before the rounds and chamfers are used.

**Step 4:** Take a screen capture to show your final design model.

**Step 5:** Create a product brief and do a screen capture of it. Refer to Exercise 7 if you have any question on creating a product brief.

*Congratulations! You have completed this exercise.*
Exercise 9

Creating Parts & Assemblies
Creating Parts & Assemblies

PLANNING AND CREATING PARTS AND ASSEMBLIES

Creating Part Model Plans

The first step in creating parts and assemblies is developing a plan. These plans help to orient the parts and assemblies and identify what operations need to be used at what point in the process of creation. We will start this section by having you develop some simple part plans and assembly plans and then have you practice on real parts and assemblies.

Complete the tables below to create a part model plan. Start by examining the sample parts below and deciding what operations need to be used to create the appropriate volumes and whether the feature should be positive or negative. You can sketch these plans on your own paper and outline the cross sections and the datums for each operation.

PART 1: SIMPLE BLOCK WITH CHAMFER AND HOLE
<table>
<thead>
<tr>
<th>Characteristics</th>
<th>Sketches</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Orientation</td>
<td><img src="image" alt="Orientation Sketch" /></td>
<td>Identify which view is TOP, FRONT and RIGHT?</td>
</tr>
<tr>
<td>Sketch 1 and Feature</td>
<td><img src="image" alt="Sketch 1" /></td>
<td>This is the first sketch. Where should it be placed? What Boolean operation should be used (extrude, revolve)? Should it be positive or negative?</td>
</tr>
<tr>
<td>Sketch 2 and Feature</td>
<td><img src="image" alt="Sketch 2" /></td>
<td>Where should the sketch be placed? What Boolean operation should be used (extrude, revolve)? Should it be positive or negative?</td>
</tr>
</tbody>
</table>
### Simple Block and Chamfer Part Model Plan

<table>
<thead>
<tr>
<th>Characteristics</th>
<th>Sketches</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Feature</td>
<td><img src="image" alt="Chamfer Sketch" /></td>
<td>A chamfer operation creates an angled edge around a hole or side.</td>
</tr>
<tr>
<td>Feature</td>
<td><img src="image" alt="Chamfer Sketch" /></td>
<td>A chamfer operation creates an angled edge along the front edge of the block.</td>
</tr>
<tr>
<td>Feature</td>
<td><img src="image" alt="Round Sketch" /></td>
<td>A round operation rounds the top and bottom edge at the back of the block.</td>
</tr>
<tr>
<td>Material</td>
<td><img src="image" alt="Material Table" /></td>
<td>Assigning a material to the part is essential to insure that the mass property calculations are correct.</td>
</tr>
</tbody>
</table>

Now try another part plan. This time we will let you sketch out the various parts of the plan so that you can develop some skill at creating these plans.
## Simple Frame Guide Part Model Plan

<table>
<thead>
<tr>
<th>Characteristics</th>
<th>Sketches</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Orientation</td>
<td><img src="image" alt="Sketch" /></td>
<td>Identify which view is TOP, FRONT and RIGHT?</td>
</tr>
</tbody>
</table>
### Simple Frame Guide Part Model Plan

<table>
<thead>
<tr>
<th>Characteristics</th>
<th>Sketches</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Feature 1</td>
<td></td>
<td>What Boolean operation should be used (extrude, revolve)? Should it be positive or negative?</td>
</tr>
<tr>
<td>Feature 2</td>
<td></td>
<td>What Boolean operation should be used (extrude, revolve)? Should it be positive or negative?</td>
</tr>
<tr>
<td>Feature 3</td>
<td></td>
<td>What Boolean operation should be used (extrude, revolve)? Should it be positive or negative?</td>
</tr>
<tr>
<td>Feature 4</td>
<td></td>
<td>A round operation might be useful at this point.</td>
</tr>
<tr>
<td>Characteristics</td>
<td>Sketches</td>
<td>Operation</td>
</tr>
<tr>
<td>-----------------</td>
<td>----------</td>
<td>-----------</td>
</tr>
<tr>
<td>Feature 5</td>
<td></td>
<td>A chamfer operation might be useful at this point</td>
</tr>
<tr>
<td>Material</td>
<td></td>
<td>What material should you assign to this part?</td>
</tr>
</tbody>
</table>
Here are some additional parts that you can practice with to ensure you know how to create a part modeling plan.
Creating Assembly Model Plans

Now that you have some skill with creating part modeling plans, let's try building an assembly model plan. Here is the plan for the red car assembly you created in exercise 5.

<table>
<thead>
<tr>
<th>Characteristics</th>
<th>Parts</th>
<th>Assembly Constraints</th>
</tr>
</thead>
<tbody>
<tr>
<td>1st Part</td>
<td>Chassis subsystem</td>
<td>Default constraint to orient it to the origin</td>
</tr>
<tr>
<td>2nd Part</td>
<td>Gearbox subsystem</td>
<td>Three coincident constraints, one on the bottom, one on the side, and one on the back of the mount.</td>
</tr>
<tr>
<td>3rd Part</td>
<td>Car body subsystem</td>
<td>Three coincident constraints, two for the sides of the poles and one for the top.</td>
</tr>
</tbody>
</table>
Using the assembly model plan for the red car assembly as an example, try to create an assembly model plan for the Deep Sea Sub model. Start by examining the parts of the assembly and deciding what operations need to be used to create the appropriate constraints for each part.

Now that you have had a chance to develop your skills in creating part model plans and assembly model plans, let’s put those skills to good use. Here is a simple crank mechanism. Create part model plans for each component and then using those plans, build them in PTC Creo Parametric. Then create an assembly model plan and use it to assemble the parts into a working mechanism. Larger versions of the drawings are available in the Crank folder.
When you assemble this crank mechanism you will need to assemble the yellow crank pieces with a slider constraint. The crank arm will need to be assembled using a pin constraint and then a cylinder constraint. There is a video file in the Crank folder that shows the working of the crank. Here are some instructions that will help with the assembly.

1. Assemble the base by selecting Default from the Automatic drop-down menu.
2. Click Assemble and select crank.prt.
3. Select Slider from the User Defined drop-down menu.
4. Left-click on the edge of the slider to select it.
5. Left-click on the corresponding edge on the base.
6. Left-click on the flat bottom surface of the slider.

7. Left-click on the flat “cross” surface of the base.

8. Repeat steps 2-6 to assemble another slider.

9. Click **Assemble** and select **crank_arm.prt**.

10. From the **User Defined** drop-down menu, select **Pin**.

11. Left-click on the inner cylindrical surface of the arm and then left-click on the cylindrical surface of the slider peg.

12. Left-click on the bottom of the arm and the top of the slider.
13. From the **Placement** tab, select **New Set**.

14. Repeat steps 11 & 12 to constrain the end of the arm to the other slider.

15. Finish by creating a drawing of one of the components in the crank mechanism.

16. Click **Open** and select **crank_arm.prt**.

17. From the **Schools** tab, select **New**.

18. Change the Type to **Drawing** and enter **Crank_arm_drawing**.

19. Click **OK**.
20. Under **Specify Template**, select **Use template**.

21. Select `c_drawing` and click **OK**.

Notice that a default set of views will be created within a formatted drawing template.

22. From the **Annotate** tab, click **Dimension**.

23. Left-click on the two references for your dimension.

24. Middle-click to place the dimension.
You can modify each view using the Properties dialog box. The properties dialog box allows you to change scale, view state, orientation, etc.

25. Left-click on a view to select it, then right-click and select Properties.

26. From the Annotate tab, select Show Model Annotations to show datums and dimensions from the part model.

27. Right-click on the cells and select Properties to add your own text.
**Review**

Now that you have had a chance to learn about model plans and the creation of parts and assemblies, let’s review the steps and operations you have completed:

1. You learned how to create part model plans
2. You then learned how to create assembly model plans
3. You assembled the crank mechanism (Steps 1-14)
4. You learned how to create a drawing (Steps 15-27)

**Practice Exercise**

Now let’s try it again with a little more complex assembly. A Geneva mechanism is used to transform rotary motion into indexed motion. You can envision it being used in an assembly line for filling bottles with fluid and then moving them on to the next station.

There is a video in the Geneva_Mechanism folder that shows its motion. The arm rotates around and engages with the yoke to turn it a specified number of degrees. Then the arm disengages and rotates around until it engages again.

Use the drawings provided here to plan and build the components for the Geneva mechanism. Larger versions of the drawings are available in the Geneva_Mechanism folder.
Create an assembly plan and then follow it to assemble the parts. Use a servo motor in the Mechanism application to animate the mechanism and make it run.

1. Create all of the parts in PTC Creo Parametric.

2. Using your assembly model plan, create the assembly.
3. You will need to use pin joints and 3D contacts to make the mechanism work.

4. Define a 3D contact connection between the round pin on the arm and each of the four flat surfaces that the pin will contact. You don’t need connections with any of the other surfaces.
5. Add a servo motor to the arm pin joint and then run an analysis to generate the Geneva Mechanism motion.

*You may have to position the blue yoke correctly to start so that the pin engages the surfaces to begin with.*

6. Create drawings for each of the parts and the assembly.
7. An assembly drawing is created by deleting all of the views except the isometric view.

8. Right-click on the isometric view and unlock it so that it can move. Place it in the center of the drawing.

9. Right-click on the view and select Properties, then select View States.

10. Select Explode components in view and click Apply.

11. If necessary, change the scale.

12. Add a bill of materials by selecting the Table tab and then selecting Table from file. Use the bill of materials file in the How to Model Almost Anything folder and place the bill of materials table on the drawing.

13. You can also add Balloons using the Create Balloons tool.
Now that you have had a chance to practice developing model plans and building parts, assemblies, and drawings, try answering these questions:

1. Why do you need to create a model plan before building parts?
2. Why should you assign materials to parts as part of the model creation?
3. Why do you need to create an assembly model plan?
4. Why do you need to identify each of the constraints you will apply during the assembly process?
5. How do you create a drawing?
6. How do you dimension within a view on a drawing?
7. How do you change the properties of a view?
8. What is a bill of materials table?
9. Why create drawings when you have a 3D model?

**FINAL ASSESSMENT**

Create an internal Geneva mechanism as the final assessment. You will need to decide the size of each of the components. Also create drawings of each of the components and an exploded assembly drawing. You will also need to create the mechanism using 3D contacts and servo motors.
**Step 1:** Develop model plans for each of the parts

**Step 2:** Develop an assembly plan

**Step 3:** Create each of the parts

**Step 4:** Assemble the parts into a working mechanism

**Step 5:** Create drawings for each of the parts

**Step 6:** Create an exploded assembly drawing (you can reference the assembly drawing exercise below)

Here is an example of how to change the exploded state of your assembly. You can use this to help you create your exploded assembly drawing.

1. From the In Graphics toolbar, select `Saved Orientations` and click `Isometric`.

2. From the In Graphics toolbar, select `View Manager`.

![View Manager](image-url)
3. From the View Manager dialog box, select the Explode tab, then click New.

4. Type My_Explode and press ENTER.

5. Select Edit, then click Save and click OK.

6. Close the View Manager dialog box.

7. From the View tab, select Edit Position.

8. Left-click on the mechanism drive wheel to select it.

9. Use the arrows to move the part up and out of the way.

10. Left-click on each of the other parts and re-locate them to your desired locations.
11. From the **Explode Lines** tab, select **Create Lines**.

12. Left-click on the corresponding cylindrical surfaces to create a reference line between them.

13. Click **Apply**.

14. Continue making lines between the base and all of the remaining parts.

15. Once all of the reference lines have been created, **Close** the **Cosmetic Offset Line** dialog box.

16. Click ✔️ **OK** to exit the Explode Tool.
17. From the View tab, use Exploded View to toggle between the exploded states of your model.

18. You can now use your new exploded view when making your exploded assembly drawing.

Congratulations! You have completed this exercise.
Exercise 10

Advanced Modeling
Advanced Modeling

DESIGNING AND CREATING NEW PART GEOMETRY

Solid Modeling Advanced Operations

In this module you are going to assume the role of an automobile product designer. You have been tasked with updating the exhaust system for the next model year vehicle. Using an extrude or revolve won’t get you the shape you’re looking for, so in this case, it would be best to use two advanced features called **Sweeps** and **Blends**.
**Blend** is taking two or more cross-sections and blending between them along a curve. The image below is an example of using blends to create the blades of a propeller. Notice in the image below how the cross-section varies as you move down the propeller. This is something you cannot accomplish with an extrude or revolve.

Let's first practice using blends to make an exhaust tip for our new car.
1. Start **PTC Creo Parametric** by double clicking on the icon or by going to the Start Menu, finding **PTC Creo Parametric**, and selecting it.

2. From the **Home** tab, **Data** group, click **Select Working Directory**.

   *Remember that this allows you to set the folder that PTC Creo Parametric will use to open and save files.*

3. Navigate to the **How to Model Almost Anything** folder:
   - Double-click the **Car** folder.
   - Click **OK**.
4. From the Home tab, click New:
   - Type “Exhaust”.
   - Click OK.

5. From the Schools tab, Features group, click Blend.

6. Assign a name to this blend by clicking on the Properties tab and entering “TIPS.”
We will start our exhaust tip with a rectangular section. Since this exhaust tip will be connected to the rest of our exhaust system, we will need to end with a circle that is the same size as our exhaust pipe. We will blend between the rectangle and the circle to create a nice aesthetic finish.

7. Select the **Sections** tab, then click **Define...** to start sketching your first section.
You need to select a plane upon which to sketch your section.

8. In the Graphics Area, left-click on the Front plane to select it.

9. In the Sketch dialog box, click Sketch.

   Notice that you can also select a different reference for the sketch or view the sketch from the other side of the plane from this dialog box.

10. From Sketch tab, select Center Rectangle.
11. Left-click on the Origin to set the center of the Rectangle.

12. Move your mouse up and to the right, then left-click again to set the size.

13. Middle-click once to exit the Center Rectangle tool.

14. Double-click on each dimension, then change the values to match the picture shown.

   Note that an orange arrow shows our Start Point for our blend. The start point is the point that will be used while blending between sketches. In order to avoid twisting in our blend, all sections need to have similar start points.

15. You can refit the view, by clicking Refit.

16. Click OK to complete the first sketch.

Now we need to define the dimension between the created section and the next section that we will create.

17. From the Sections tab, make sure Section 2 is selected.

18. Change the dimension to 0.25
19. Create another rectangle centered at the origin with the dimensions shown.

*It’s important that this rectangle has the same starting point as our first section. If it doesn’t, select the point you want to start from, right-click, and select **Start Point**.*

20. Click ✓ **OK**.

21. From the **Sections** tab, select **Insert** to create a new section.

22. Set the offset value to .175 and click **Sketch...**
23. Create a **Center and Point** circle with the center at the origin.

24. Set the diameter to **0.10** and press **ENTER**.

---

**Each section in a blend has to have the same number of vertex points. Because rectangles have 4 points (the corners), we need to add 4 vertex points to the circle.**

25. From the **Sketch** tab, select **Centerline**.

26. Create two centerlines that pass through the middle of the circle as shown.

27. Change the angles of the centerlines to match the dimensions shown.

*If one of the angle dimensions doesn’t show up, you can use the Normal tool to add dimensions. First select the Normal from the Sketch tab, then left-click on the two rays of the angle. Middle-click to set the dimension.*
28. From the **Sketch** tab, expand the menu under **Editing** and select **Divide**.

29. Starting at the top-left corner of the circle, click to place a point at each intersection as shown.

30. Click ✓ **OK**.

31. If you’re happy with the shape of your blend, click ✓ **OK**.

Now that the basic shape of our Blend is finished, we’ll use rounds to take off some of the sharp corners.

32. From the **Schools** tab, select **Round**.

33. Change the radius to 0.01, then hold **CTRL** and left-click each of the edges shown.

34. Click ✓ **OK** to accept.
35. Repeat steps 31 & 32 to round the four edges shown to a radius of 0.03.

36. Click OK.

Now that we have the Blend volume for the tips, we may start creating the rest of the exhaust. We will make all of the exhaust system as a single part.

For the exhaust pipe, we will need to use another feature called a **Sweep**. A **Sweep** is taking a cross-section and sweeping it along a curve as shown below.
Unlike a Blend, a Sweep requires you to define the path that your sweep will travel along. We'll do this by making a sketch in our model first.

37. From the *Schools* tab, select Sketch.

38. Select the datum plane **TOP** and click Sketch in the dialog box.
39. From the **Sketch** tab, select **References**.

40. Left-click on the bottom edge of the exhaust tip as shown to select it as a reference.

41. In the Reference dialog box, click **Close**.

42. Use the **Line Chain** tool to create a sketch like the one shown.

43. Use **Normal** by left-clicking on the line, then middle-clicking to place a dimension for each line.

44. Once your sketch matches the image, click **OK**.

   *This will be the path that our Sweep will follow.*

45. With Sketch 1 selected, click **Sweep**.

46. In the **Sweep** tab, select **Create or edit sweep section**.
47. Create a circle at the origin with a diameter of 0.10 as shown.

48. Click ✓ OK.

49. Rotate your model and notice how the circular cross-section follows the sketch we drew earlier.

50. If you’re satisfied with your sweep, click ✓ OK.

Now that the shape of our exhaust is complete, we just need to hollow it out.

51. From the Schools tab, select Shell.

52. Change the thickness to 0.005 and press ENTER.

53. Hold CTRL and left-click on the two surfaces shown in order to remove them.

54. Click ✓ OK.
55. Select **File>Save**.

56. Click **OK**.

As you can see, Sweeps allows us to create shapes that we wouldn’t otherwise be able to make.

Now that our exhaust system is complete, we just need to add it to the car.
57. From the **Schools** tab, select ![Open](open.png).

58. Select **car.asm** and click **Open**.

59. From the In Graphics toolbar, make sure that only **Plane Display** is turned on.

60. From the **Schools** tab, click ![Assemble](assemble.png).

61. Select **exhaust.prt** and click **Open**.

62. Left-click to place the exhaust near the back of the car.

63. To make the assembly easier, use the Orientation Sphere to orient the system as shown.
64. Select the cylindrical end of the exhaust system.

65. Rotate the car and select the yellow surface underneath the chassis.

66. Select the TOP datum plane from the exhaust system.

67. Change the constraint type from **Coincident** to **Parallel**.

68. Select the **ASM_TOP** datum plane from the Model Tree.

69. Select the flat end of the exhaust system.

70. Select the flat green surface under the chassis.

71. If necessary, change the constraint from **Distance** to **Coincident**.
72. Click OK.

Your modified exhaust system is now assembled to the undercarriage of your chassis.
Review

Now that you have learned how to make Sweeps and Blends, let’s review the steps and operations you have completed:

1. You learned how to create a multiple section Blend (Steps 5-30)
2. You practiced added rounds to your model (Steps 31-35)
3. You learned how to add References in a Sketch (Steps 38-40)
4. You practiced creating a sketch and adding dimensions (Steps 41-43)
5. You learned how to create a sweep from an existing sketch (Steps 44-49)
6. You practiced using the Shell tool to hollow out a model (Steps 50-53)
7. You assembled your finished exhaust system onto the car (Steps 56-71)
Practice Exercise

Let’s try using Blends and Sweeps to improve the car body.

1. Using two Blends, try to add side mirrors to the Car Body. First blend from a triangle to a circle. Then blend through 3 or 4 trapezoids.

2. Add an Aileron. First add blends for the supports, then Sweep the airfoil of it.

Now that you have had a chance to practice blends and sweeps, try answering these questions:

1. What is a blend and why do we use it to create geometry?
2. Explain why you need closed sketches to create the volumes of your model.
3. Why do Sections need the same number of vertexes?
4. What do we do if the blend volume is twisted?
5. How do we add vertexes to a circle?
6. How can we move the starting point of a section?
7. What is a sweep and why do we use it to create geometry?
8. How do you make the path for a sweep?
9. How do you make a model hollow?
FINAL ASSESSMENT

Now try what you learned with an older model. Set your working directory to Candy, and try using Sweep and Blend to create a complex geometry for the candy. Here are some examples for you.

Ex. 1: The base section is a square and the top section is a 4 corners star from Palette Gallery.

Ex. 2: The base section is a 8 sides Octagon and the top section is a 8-tip star from Palette Gallery.

Congratulations! You have completed this exercise.
Exercise 11

A Virtual Laboratory
A Virtual Laboratory

USING PTC CREO TO SIMULATE THE REAL WORLD

An important part of product development is simulation. Creo makes it easy to simulate the real world. It becomes a virtual laboratory where all kinds of tests can be conducted without anyone getting hurt.

Creo was developed so that engineers and designers could do simulations and predict how a product or part would react to given loads and conditions. In this way, Creo becomes a virtual laboratory where experiments of all types can be created and performed.
Creo is like a virtual laboratory where parts and products can be explored and tested. Even human factors like aesthetics and ergonomics can be explored using manikin models.

This virtual laboratory capability allows us to bring things into our virtual laboratory that we would have a hard time doing in real life, like driving a jet aircraft into the lab. Not only is it possible to do experiments that you couldn’t do otherwise, but the safety concerns are eliminated as well.
Most of the simulation that we will be doing in these exercises will be using the Mechanism application where motion can be simulated. There are other applications as well that allow forces and stresses to be calculated, in addition to heat transfer and flow dynamics.

Let’s begin by running a simple experiment with 3 rubber balls and a container that will let them bounce. We will change the level of gravity so that we can study the behavior of the bouncing balls on Earth, Mars, and the International Space Station.

**BIG IDEA: Gravitational attraction and conservation of energy during the bouncing ball collisions**

Everyone has experienced the force of gravity and felt it pull you towards the center of the earth. The force of gravity causes balls to be drawn toward earth thus creating kinetic energy because of the motion of the balls. When the balls encounter the floor or ground they experience a collision. The energy is conserved either through transforming it to heat and sound or through the restitution of bouncing in the opposite direction. The extent to which the energy is conserved through bouncing is measured in the coefficient of restitution.
The closer the coefficient of restitution is to the value of 1 the better a ball bounces. The closer it is to the value of 0 the quicker its bounces die out. These effects of bouncing are properties of the materials the balls are made from and can be modeled using Creo’s virtual lab capabilities.
Using the bouncing balls virtual laboratory you will explore gravity and the coefficient of restitution and learn about how they interact. You will learn how to explore different gravity fields and different materials’ coefficients of restitution.

Let’s begin by defining potential and kinetic energy. Potential energy is a measure of the stored energy in a system. There are many forms of potential energy, but the most common is associated with gravitational fields. When a ball is placed above the floor, there is the potential for it to drop to the floor. The energy is the result of the gravitational forces which pull the ball toward the center of the earth. The amount of potential energy is proportional to the height above a reference point such as the floor. It is easy to create an equation that represents potential energy,

\[ PE = mgh \]

where \( m \) is the mass and \( g \) is the gravitational constant, and \( h \) is the height above the floor or ground.

Kinetic energy is energy associated with movement. The faster something is moving, the more kinetic energy it has. Once the ball hits the floor and bounces we can measure the coefficient of restitution by measuring the velocity before and after the collision.
\[ C_R = \frac{V_{after}}{V_{before}} \]

This means the coefficient of restitution is a percentage. It represents how much energy is lost during the collision to heat and noise. If the coefficient is 1.0 then it means no energy is lost or the ball returns to the same height as when it was dropped. If it is 0.0 it means all the energy is lost and the ball will not bounce.

Let’s begin exploring gravity and bouncing through a virtual lab.

1. Start **PTC Creo Parametric** by double-clicking on the icon or by going to the Start Menu, finding **PTC Creo Parametric**, and selecting it.

2. From the **Home** tab, **Data** group, click **Select Working Directory**.

   *Remember that this sets the folder that PTC Creo will use to open and save files.*
3. Navigate to the **How to Model Almost Anything** folder:
   - Double-click the **Bouncing_Balls** folder.
   - Click **OK**.

4. From the **Home** tab, click **Open**
   - Double-click **balls.asm**.

5. From the In Graphics toolbar:
   - Click **Datum Display Filters**, and disable the display of all datum features.

6. From the **Schools** tab, click **Mechanism**.
   
   *The Mechanism mode is a virtual laboratory where you can perform different experiments with the model.*
Let’s explore the model.

You will notice there are 3D contact connections between the three balls and the inner walls of the container as represented by the dashed lines.

7. From the **Mechanism** tab, click **Mechanism Analysis**.

The Analysis Definition dialog box will appear.

8. From the **Analysis Definition** dialog box, select **Dynamic** from the **Type** drop-down menu.

9. Change the **Name** to **Earth**.

10. Set the **Duration** to 10 and the **Frame Rate** to 10.

11. Click **I.C. State** to use the initial conditions set up in the model.
12. Select the **External Loads** tab.

13. Click **Enable Gravity**.

14. Click **Run**.

You will notice that the calculations slow down when the balls are about to hit the walls. This is because it requires many more calculations once the balls get close to a collision.

15. After the analysis finishes, click **OK** in the **Analysis Definition** dialog box.
Let’s replay the analysis.

16. From the Mechanism Tree, expand **PLAYBACKS**.

17. Right-click **Earth** and select **Play**.

18. Use the **Animate** dialog box to replay the analysis. You can change the speed of the playback using the slider.

   *This also allows you to rotate the model while it is playing back to see it from all angles.*
Creo gives you the ability to create a video from the analysis.

19. From the Animate dialog box, click Capture.

20. In the Name field, type EARTH.

   The Capture dialog box allows you to change many other settings for the video.

21. Click OK to create the video.

22. Close the Animate dialog box.

Now let’s explore different gravity fields.

23. From the Mechanism tab, Properties and Conditions group, click Gravity.

Notice that the Magnitude of gravity is 386 in/sec^2, which if you divide by 12in, is 32.174 ft/sec^2. This is the force of Earth’s gravity.

Also notice the direction is in the negative Y direction.
Mars’ gravity is about 1/3 of Earth’s gravity.

24. Under **Magnitude**, type \( \frac{386}{3} \) and press **ENTER**.

25. Click **OK**.

We need to reset the experiment so that the balls are at the top again. The model was built with an initial condition which allows us to reset it.

26. From the **Mechanism** tab, click \( \text{Drag Components} \).

27. In the **Drag** dialog box, click to expand **Snapshots**.

28. Double-click **Snapshot 1**.

   *Notice that this resets the balls to their initial position.*

29. Click **Close**.
Let’s examine our initial conditions.

30. From the Mechanism Tree, expand INITIAL CONDITIONS.

31. Right-click InitCond1 (BOUNCING_BALLS) and select Edit Definition.

32. From the Initial Condition Definition dialog box, click Pt velocity 1 to see the magnitude and direction of the initial velocity for the blue ball.

You can check the initial velocity for each of the balls by clicking on the specific Velocity Conditions entries.

33. Click OK.
34. From the **Mechanism** tab, click **Mechanism Analysis**.

35. From the **Analysis Definition** dialog box, select **Dynamic** from the **Type** drop-down menu.

36. Change the **Name** to **Mars**.

37. Make sure the **Duration** and **Frame Rate** are set to 10.

38. Click **I.C. State** to use the initial conditions set up in the model.

39. Select the **External Loads** tab.

40. Click **Enable Gravity**.

41. Click **Run**.

42. Once the analysis finishes, click **OK**.
43. From the Mechanism Tree, expand **PLAYBACKS**.

44. Right-click **Mars** and select **Play**.

45. Use the **Animate** dialog box to replay the analysis.

   *Notice that the balls bounce higher this time because they're under less gravitational force.*

46. From the **Animate** dialog box, click **Capture**.

47. In the **Name** field, type **MARS**.

48. Click **OK** to create the video.

49. Close the **Animate** dialog box.

50. Repeat steps 23 – 48 and set the gravity to **0.00001**.

   *This is approximately the gravity on the International Space Station. It is known as “micro-gravity”.*

51. Name the analysis and the captured video **ISS**.
52. From the Quick Access Toolbar, click **Save**.

53. Navigate to the **Bouncing_Balls** folder and open each of the video files to compare the effects of gravity.
Review

Now that you have had a chance to learn about PTC Creo’s virtual lab capabilities, let’s review the steps and operations you have completed:

1. You learned about how PTC Creo Parametric can be a virtual laboratory
2. You learned about the coefficient of restitution
3. You learned how to run an analysis
4. You learned how to capture the results as a video
5. You learned how to change the gravity in the analysis (Steps
6. You then ran two more analyses to test bouncing under Mars gravity and ISS gravity

Before we move to a new model, let’s explore how the bouncing balls experiment was created.

54. From the Mechanism Tree, expand CONNECTIONS, then expand 3D CONTACTS.

55. Right-click Contact 1 (BOUNCING_BALLS) and select Edit Definition.
56. Select the **References** tab.

*Notice that the 3D contacts have been set up between the blue ball and all of the interior sides of the yellow box.*

![Image of References tab showing 3D contacts set up between a blue ball and a yellow box]

57. Select the **Contact** tab.

*Notice that the values for Damping are very small. The damping coefficient is the inverse of the coefficient of restitution. You can see that these balls have very little energy loss during their collisions. All of these values can be set based upon the situation you are trying to simulate.*

![Image of Contact tab showing damping values and properties]

58. From the **Schools** tab, click **Close**.

59. From the **Home** tab, **Data** group, click **Erase Not Displayed**.

60. Click **OK** to clear the session from memory.
Now let’s try a little bit different type of collision. Newton’s Cradle is a popular type of toy and teaching demonstration. It demonstrates how momentum and energy are conserved in collisions.

We will use a model of Newton’s Cradle to explore other options in simulating the real world.

1. From the **Home** tab, **Data** group, click **Select Working Directory** 📄

2. Navigate to the **How to Model Almost Anything** folder:
   - Double-click the **Newton’s_Cradle** folder.
   - Click **OK**.

3. From the **Home** tab, click **Open** 📄:
   - Double-click **cradle.asm**.
4. From the **Schools** tab, click **Mechanism**.

   Notice the connections between the balls are now highlighted. These are called **Cam-Follower connections**.

5. From the Mechanism Tree, expand **CONNECTIONS** and **CAMS**.

6. Right-click on **Cam Follower1 (CRADLE)** and select **Edit Definition**.

   Notice the white and purple arrows indicate the direction of movement. The purple arrow is Cam1 and the white one is Cam2.

7. From the **Cam-Follower** dialog box, select **Properties** to see information about this connection.

   Notice that liftoff has been enabled and the coefficient of restitution is set at 0.998. Curves were created around the circumference of the balls and selected as the Cams.
8. Use your knowledge of running analyses to run the **One_Ball** and **Three_Ball** analyses in the Mechanism Tree.

9. Create videos of each analysis to compare the results.

10. Try making your own analysis with a different number of balls raised up to start.

11. From the **Schools** tab, click **Close**.

12. From the **Home** tab, **Data** group, click **Erase Not Displayed**.

13. Click **OK** to clear the session from memory.

Answer these questions before going on to the final assessment:

1. How does PTC Creo function like a virtual laboratory?
2. What is the coefficient of restitution?
3. What application allows you to simulate mechanisms?
4. What two types of connections allow you to simulate collisions?
5. How does Newton’s cradle show that energy and momentum is conserved?
1. Set your working directory to the Chemical_Reactions folder and open chemical_behavior.asm.

2. You will see a vacuum tube filled with a few molecules of water and methane.

3. Open the Mechanism tool and run the **Low_Energy** analysis.

4. Use the Animate dialog box to capture a video of the analysis.

   *Note that this analysis can take a while to run since it requires a great deal of memory.*

5. Examine the two Initial Conditions (**Low_energy & High_energy**) in the Mechanism Tree to determine the differences.

6. Run the **High_Energy** analysis and save a video of the animation.
7. Why is it more likely that two of the molecules will collide at a higher energy state?

Congratulations! You have completed this exercise.
Calculating Stresses

Introduction

One of the most important aspects of modeling parts and products is ensuring that the individual components and connections are going to hold up under a load. One of the most important measures for determining this is the stress in a material. Stress can be thought of as the effect of a force applied over an area. If there is too much stress in a material, it will break. Each material has different limits for its maximum stress.

Another important measure to keep in mind is the total displacement. Displacement is the distance that the material stretches or moves when subjected to a load. If the material stretches too far, it will break.
Fortunately, PTC Creo Simulate allows us to quickly and easily analyze the stress and displacement of a model under a load. This allows us to predict how the model will function before building it out of solid materials.

Let’s start by analyzing a hook from a robot and determining how it will react while supporting the robot’s weight.

1. Start PTC Creo Parametric by double-clicking on the icon or by going to the Start Menu, finding PTC Creo Parametric, and selecting it.

2. From the Home tab, Data group, click Select Working Directory.

   Remember that this sets the folder that PTC Creo will use to open and save files.

3. Navigate to the How to Model Almost Anything folder:
   - Double-click the FTC_Robot folder.
   - Click OK.
4. From the **Home** tab, click **Open**:  
   • Double-click **0_ftc_robot.asm**.

5. From the **In Graphics** toolbar:
   • Click **Datum Display Filters** and disable the display of all datum features.

6. From the **Analysis** tab, click **Mass Properties**.

7. From the **Mass Properties** dialog box, click **Preview** to calculate the measures of the model.

   *Notice that Creo automatically calculates the volume, surface area, mass, and many other properties of the model. Note that the mass of the robot is 43.29 pounds. We will use this to determine the load on the hooks.*

8. Click **OK**.
9. From the Model Tree, right-click on HOOK.PRT and select Open.

You now have the part model of the hook open and will be able to run a stress analysis on the hook.

10. From the Applications tab, click Simulate.

PTC Creo Simulate tool is a virtual lab that allows you to apply forces, constraints, and materials to your model and analyze the reactions.

If prompted, click OK and enter Simulate Lite. The Process Guide will walk us through the setup of the simulation.

11. From the Process Guide dialog box, click Materials, and then click assign.

Notice that a material has already been assigned for this part. To change the material used, you could click More...

12. From the Material Assignment dialog box, click OK.
13. From the **Process Guide** dialog box, click **Next**, and then click **constraints**.

   *Constraints are used to fix portions of the model in a stationary position. In this case, we want to simulate the hook hanging on a bar, so we will constrain the inner “hook” surfaces.*

14. In the **Constraints Manager** dialog box, click **Create a displacement constraint**.

15. In the Graphics Area, left-click to select the surface shown.

16. In the **Constraint** dialog box, ensure that all of the Translation directions are set to **Fixed**.

   *This means the constraint will restrict the model from moving in any direction.*

17. Click **OK**.
18. Repeat steps 14 – 17 to assign another constraint to the curved surface shown.

19. In the **Constraints Manager** dialog box, click **Close**.

20. From the **Process Guide** dialog box, click **Next**, and then click **loads**.

   *Loads are used to simulate forces on an object. In this case, our load will be the weight of our robot.*

21. In the **Loads Manager** dialog box, click **Create a force/moment load**.

22. In the Graphics Area, select the bottom flat surface of the hook.

23. In the **Force/Moment Load** dialog box, enter **-8363.63** in the **Y-Component** box.

   *This is half of the weight of our total robot. Because the robot will be hanging from two hooks and is symmetrical, we can just divide the weight between the hooks. Weight can be found by multiplying the mass of our robot (43.29lbs) by the gravitational*
constant (386.4 in/s²).

24. Click OK.

25. Close the Loads Manager dialog box.

In the IN-LB unit system, pounds are used to describe two different measures: mass (lbm) and weight (lbf). Weight is actually a measure of force. To find weight, you multiply the mass of the object by the gravitational constant (32.2 ft/s²).


27. Click Run to start the analysis.

28. Once the analysis finishes, click Close in the Diagnostics dialog box.

29. In the Process Guide dialog box, click Next, and then click results.

The results of the analysis will be displayed. Three different windows will pop up: the von Mises Stress, the Displacement, and the Max Principal Stress. These are color coded and animated to show the weak points and movement of the
Review

Now that you have had a chance to learn about PTC Creo Simulate, let’s review the steps and operations you have completed:

1. You learned about stress and displacement in a model (Introduction)
2. You learned how to calculate the mass and volume of a model (Steps 1-8)
3. You learned how to bring a model into Creo Simulate (Steps 9-10)
4. You learned how to assign a material to your model (Steps 11-12)
5. You learned about constraints and how to add them to your model (Steps 13-19)
6. You learned how to calculate loads and add them to your model (Steps 20-25)
7. You ran the analysis and viewed the results (Steps 26-29)

Now that you’ve learned how to set up an analysis, let’s take a look at another analysis using a different type of load. A pressure load can be used to simulate pressure on a surface from gasses or liquids.
1. From the **Home** tab, **Data** group, click **Select Working Directory**.

2. Navigate to the **How to Model Almost Anything** folder:
   - Double-click the **Pressure_Tank** folder.
   - Click **OK**.

3. From the **Home** tab, click **Open**:
   - Double-click **tank.prt**.

4. **We’ll use this model to simulate a propane storage tank under double the recommended pressure. This will allow us to see what would happen if we overloaded the tank.**

5. From the **Applications** tab, click **Simulate**.

5. Use the **Process Guide** dialog box to examine the Materials in the model.
   - **What kind of material is the tank made out of?**
6. Explore the Constraints in the model.

Notice that the bottom flat surface of the tank is constrained in every direction and can’t move.

7. Examine the loads on the model.

8. In the Loads Manager dialog box, click on each individual load to view it.

Notice that all of the pressure loads are on the inside of the tank pressing out. The loads are set to 500 psi, which is twice the recommended load for a propane tank.

9. Use the Process Guide dialog box to run the analysis and view the results.

Where is the area of maximum deflection on the tank? How much will it move? Where is the area of maximum stress?
10. Close the Simulate Results window without saving.


12. From the Schools tab, click Close.

13. From the Home tab, Data group, click Erase Not Displayed.

14. Click OK to clear the session from memory.

Answer these questions before going on to the final assessment:

1. How can you use Creo Simulate to analyze a model?
2. What does it mean to apply a constraint to a model?
3. What does it mean to apply a load to a model?
4. What does the deflection indicate?
5. How can you tell which area has the highest stress?

**FINAL ASSESSMENT**

1. Set your working directory to the AndyMark_Chassis folder and open am14u_wide.asm.

2. You are going to use Creo Simulate to analyze the load on one of the cross members of the chassis.
3. Click **Open** and double-click **am-2595.prt**.

4. From the **Applications** tab, click **Simulate** and enter **Simulate Lite**.

5. Assign the material **metal_aluminum_aa2024** to the model.

6. Constrain both ends of the channel to be completely fixed.
7. Place a load on the top two flat surfaces of 800 lbs force (this is equal to about 25 lbs mass).

You’ll need to hold CTRL in order to select both surfaces.

8. Run the analysis and view the results.

The analysis might take a while to finish. Be patient and wait for the Diagnostics window to appear.

9. Use your knowledge of stress and displacement to analyze the results.

Where is the area of maximum displacement? Maximum stress? What are the values?

Congratulations! You have completed this exercise.
How to Model Almost Anything

Have you always been interested in 3D modeling but thought it would be too difficult to learn on your own? Are you interested in learning how to design your own parts for 3D printing?

This text will provide you with an easy to follow curriculum that will have you building 3D models very quickly. It has 12 different exercises and 18 unique pre-assembled models for you to work with. Learn about 3D design and how to use the product development process to turn your great ideas into 3D models that can move just like their physical counterparts. Practice your basic 3D design skills by assembling multiple models and creating your very own parts in PTC® Creo®.

Praise for How to Model Almost Anything

“'How to Model Almost Anything' is an incredibly awesome starting point. I found it really easy to understand and it got me started and able to draft well quickly.” – T. Long, FIRST Robotics student

“I wanted to thank you for the great tutorial How to Model Almost Anything... It’s really wonderful, I can’t say that enough!” – M. Raikhlin, University Student

“As an educator, I recognize the importance of promoting and encouraging students to pursue STEM fields in college and careers, and the How to Model Almost Anything curriculum [is] a valuable tool to support them in that pursuit.” - P. Flanagan, High School Educator

PTC (NASDAQ: PTC) enables manufacturers to achieve sustained product and service advantage. PTC's technology solutions help customers transform the way they create, operate and service products for a smart, connected world. Founded in 1985, PTC employs approximately 6,000 professionals serving more than 28,000 businesses in rapidly-evolving, globally distributed manufacturing industries worldwide.

PTC believes that the sustained success of our company, our customers, and society depends upon empowering each generation to innovate in solving real world economic, social, and environmental challenges. For more than ten years, our team of engineers and educators have been working with students and educators to enhance the teaching and learning of science, technology, engineering and math (STEM) education.

www.PTCK12.com